summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO35
-rw-r--r--PKGBUILD72
-rw-r--r--fix_about_dialog.patch91
-rw-r--r--noupdatecheck.patch173
-rw-r--r--universalindentgui.desktop10
-rw-r--r--universalindentgui.pngbin0 -> 1730 bytes
6 files changed, 381 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d0ede2617306
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,35 @@
+# Generated by makepkg 4.2.1
+# Tue Mar 17 01:05:05 UTC 2015
+pkgbase = universalindentgui-svn
+ pkgdesc = A GUI for GNU Indent, Uncrustify, Artistic Styler, PHP Stylist, Ruby Beautify, HTML Tidy and many other
+ pkgver = r1077
+ pkgrel = 1
+ url = http://universalindent.sourceforge.net
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = subversion
+ depends = qt4
+ depends = qscintilla
+ optdepends = astyle: a free, fast and small automatic formatter for C, C++, C# and Java,
+ optdepends = ident: the GNU pretty-printer,
+ optdepends = tidyhtml: a tool to tidy down your HTML code,
+ optdepends = uncrustify: source code beautifier for C-like languages
+ optdepends = ruby: needed for some scripts
+ optdepends = python: needed for some scripts
+ optdepends = gawk: needed for some scripts
+ provides = universalindentgui
+ conflicts = universalindentgui
+ source = universalindent-code::svn://svn.code.sf.net/p/universalindent/code/trunk
+ source = universalindentgui.desktop
+ source = universalindentgui.png
+ source = noupdatecheck.patch
+ source = fix_about_dialog.patch
+ sha256sums = SKIP
+ sha256sums = e6ed8674345d76c1f3e5ab4d6f23b64bfa7ba77141436ff325d72a28cb672a06
+ sha256sums = cc01fcc94cc2067e499b15189a2ac56a901562218951bd77650cf8f81bcf440d
+ sha256sums = b5b4d6b5604fbaaa8578a97e3a59c709bb0e1861ffaae1add3ca4452c76b5686
+ sha256sums = 254e237064e8422b4d219fadfaa8486a5a69b3561b8aa81df8faf3c13272e7c5
+
+pkgname = universalindentgui-svn
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..03f860f3c59b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,72 @@
+# Maintainer: fenugrec
+# Contributor: Schnouki <thomas.jost@gmail.com>
+# patches from universalindentgui
+pkgname=universalindentgui-svn
+pkgver=r1077
+pkgrel=1
+pkgdesc="A GUI for GNU Indent, Uncrustify, Artistic Styler, PHP Stylist, Ruby Beautify, HTML Tidy and many other"
+url="http://universalindent.sourceforge.net"
+arch=('i686' 'x86_64')
+license=('GPL')
+provides=('universalindentgui')
+conflicts=('universalindentgui')
+depends=('qt4' 'qscintilla')
+makedepends=('subversion')
+optdepends=(
+ 'astyle: a free, fast and small automatic formatter for C, C++, C# and Java',
+ 'ident: the GNU pretty-printer',
+ 'tidyhtml: a tool to tidy down your HTML code',
+ 'uncrustify: source code beautifier for C-like languages'
+ 'ruby: needed for some scripts'
+ 'python: needed for some scripts'
+ 'gawk: needed for some scripts'
+)
+
+_svnmod=universalindent-code
+source=("$_svnmod::svn://svn.code.sf.net/p/universalindent/code/trunk"
+ "universalindentgui.desktop"
+ "universalindentgui.png"
+ "noupdatecheck.patch"
+ "fix_about_dialog.patch"
+ )
+
+sha256sums=('SKIP'
+ 'e6ed8674345d76c1f3e5ab4d6f23b64bfa7ba77141436ff325d72a28cb672a06'
+ 'cc01fcc94cc2067e499b15189a2ac56a901562218951bd77650cf8f81bcf440d'
+ 'b5b4d6b5604fbaaa8578a97e3a59c709bb0e1861ffaae1add3ca4452c76b5686'
+ '254e237064e8422b4d219fadfaa8486a5a69b3561b8aa81df8faf3c13272e7c5')
+
+prepare() {
+ cd ${srcdir}
+ if [ -d $_svnmod/.svn ]; then
+ (cd $_svnmod && svn up)
+ fi
+
+ cd "$srcdir/$_svnmod"
+ #patch -Np1 -i ../../no-strip.patch src/UniversalIndentGUI.pro #disable QT stripping
+ patch -p1 -i ../noupdatecheck.patch
+ patch -p1 -i ../fix_about_dialog.patch
+}
+
+pkgver() {
+ cd "$srcdir/$_svnmod"
+ local ver="$(svnversion)"
+ printf "r%s" "${ver//[[:alpha:]]}"
+}
+
+build() {
+ cd "$srcdir"
+ cp -r $_svnmod $_svnmod-build
+ cd $_svnmod-build
+
+ qmake-qt4 UniversalIndentGUI.pro
+
+ make
+}
+
+package() {
+ install -Dm644 universalindentgui.png "$pkgdir"/usr/share/pixmaps/${pkgname}.png
+ install -Dm644 universalindentgui.desktop "$pkgdir"/usr/share/applications/${pkgname}.desktop
+ cd "$srcdir/$_svnmod-build"
+ make INSTALL_ROOT=${pkgdir} install
+}
diff --git a/fix_about_dialog.patch b/fix_about_dialog.patch
new file mode 100644
index 000000000000..8814cc34965e
--- /dev/null
+++ b/fix_about_dialog.patch
@@ -0,0 +1,91 @@
+diff --git a/src/AboutDialog.ui b/src/AboutDialog.ui
+index 0e1e9d7..4c2a93a 100755
+--- a/src/AboutDialog.ui
++++ b/src/AboutDialog.ui
+@@ -35,42 +35,11 @@
+ </property>
+ <item>
+ <widget class="QFrame" name="frame">
+- <property name="styleSheet">
+- <string notr="true">QFrame#frame { background-color: qlineargradient( x1:0, y1:0, x2:0, y2:1, stop:0 #FFFF60, stop:0.5 #D8C304, stop:1 #FFFF60 ); border: 2px solid #A89C57; border-radius: 4px;}</string>
+- </property>
+ <property name="frameShape">
+ <enum>QFrame::StyledPanel</enum>
+ </property>
+ <layout class="QVBoxLayout">
+ <item>
+- <widget class="QLabel" name="bannerLabel">
+- <property name="sizePolicy">
+- <sizepolicy hsizetype="Fixed" vsizetype="Fixed">
+- <horstretch>0</horstretch>
+- <verstretch>0</verstretch>
+- </sizepolicy>
+- </property>
+- <property name="minimumSize">
+- <size>
+- <width>570</width>
+- <height>87</height>
+- </size>
+- </property>
+- <property name="maximumSize">
+- <size>
+- <width>570</width>
+- <height>87</height>
+- </size>
+- </property>
+- <property name="text">
+- <string/>
+- </property>
+- <property name="pixmap">
+- <pixmap resource="../resources/Icons.qrc">:/aboutDialog/banner.png</pixmap>
+- </property>
+- </widget>
+- </item>
+- <item>
+ <widget class="QTextBrowser" name="versionTextBrowser">
+ <property name="sizePolicy">
+ <sizepolicy hsizetype="Expanding" vsizetype="Preferred">
+@@ -139,7 +108,7 @@ p, li { white-space: pre-wrap; }
+ <item>
+ <widget class="QTextBrowser" name="creditsTextBrowser">
+ <property name="styleSheet">
+- <string notr="true">QTextBrowser#creditsTextBrowser{border:2px solid rgba(0,0,0,10%); background-color:qlineargradient(spread:pad, x1:0, y1:0, x2:0, y2:1, stop:0 rgba(0,0,0,80%), stop:0.1 rgba(0,0,0,15%), stop:0.9 rgba(0,0,0,15%), stop:1 rgba(0,0,0,80%) )}</string>
++ <string notr="true">QTextBrowser#creditsTextBrowser{background-color: transparent; border-top: 1px solid #333;}</string>
+ </property>
+ <property name="frameShape">
+ <enum>QFrame::NoFrame</enum>
+@@ -166,9 +135,6 @@ p, li { white-space: pre-wrap; }
+ </item>
+ <item>
+ <widget class="QPushButton" name="okButton">
+- <property name="styleSheet">
+- <string notr="true">QPushButton#okButton { background-color: qlineargradient( x1:0, y1:0, x2:0, y2:1, stop:0 #DCB28A, stop:0.5 #B8784B, stop:1 #DCB28A ); border: 2px solid #A89C57; border-radius: 4px;} QPushButton:hover#okButton { background-color: qlineargradient( x1:0, y1:0, x2:0, y2:1, stop:0 #B8784B, stop:0.5 #DCB28A, stop:1 #B8784B ); } QPushButton:pressed#okButton{ border: 2px solid #D8CB75 }</string>
+- </property>
+ <property name="text">
+ <string> OK </string>
+ </property>
+diff --git a/src/AboutDialogGraphicsView.cpp b/src/AboutDialogGraphicsView.cpp
+index d97cc70..cea44b6 100755
+--- a/src/AboutDialogGraphicsView.cpp
++++ b/src/AboutDialogGraphicsView.cpp
+@@ -80,7 +80,6 @@ AboutDialogGraphicsView::AboutDialogGraphicsView(AboutDialog *aboutDialog, QWidg
+
+ setVerticalScrollBarPolicy(Qt::ScrollBarAlwaysOff);
+ setHorizontalScrollBarPolicy(Qt::ScrollBarAlwaysOff);
+- setStyleSheet("AboutDialogGraphicsView { border: 0px; }");
+
+ _timeLine = new QTimeLine(1000, this);
+ _timeLine->setFrameRange(270, 0);
+diff --git a/src/MainWindow.cpp b/src/MainWindow.cpp
+index f0f5251..bafd99b 100755
+--- a/src/MainWindow.cpp
++++ b/src/MainWindow.cpp
+@@ -122,7 +122,7 @@ MainWindow::MainWindow(QString file2OpenOnStart, QWidget *parent) : QMainWindow(
+
+
+ // Generate about dialog box
+- _aboutDialog = new AboutDialog(this, Qt::SplashScreen);
++ _aboutDialog = new AboutDialog(this);
+ _aboutDialogGraphicsView = new AboutDialogGraphicsView(_aboutDialog, this);
+ connect( _toolBarWidget->pbAbout, SIGNAL(clicked()), this, SLOT(showAboutDialog()) );
+ connect( _mainWindowForm->actionAbout_UniversalIndentGUI, SIGNAL(triggered()), this, SLOT(showAboutDialog()) );
diff --git a/noupdatecheck.patch b/noupdatecheck.patch
new file mode 100644
index 000000000000..3904a99b9ab1
--- /dev/null
+++ b/noupdatecheck.patch
@@ -0,0 +1,173 @@
+diff --git a/UniversalIndentGUI.pro b/UniversalIndentGUI.pro
+index 67f4f95..1bb4bec 100755
+--- a/UniversalIndentGUI.pro
++++ b/UniversalIndentGUI.pro
+@@ -158,7 +158,6 @@ HEADERS += src/AboutDialog.h \
+ src/UiGuiSettingsDialog.h \
+ src/UiGuiSystemInfo.h \
+ src/UiGuiVersion.h \
+- src/UpdateCheckDialog.h \
+ src/debugging/TSLogger.h
+
+
+@@ -166,7 +165,6 @@ FORMS += src/MainWindow.ui \
+ src/ToolBarWidget.ui \
+ src/UiGuiSettingsDialog.ui \
+ src/AboutDialog.ui \
+- src/UpdateCheckDialog.ui \
+ src/debugging/TSLoggerDialog.ui
+
+ SOURCES += src/AboutDialog.cpp \
+@@ -184,7 +182,6 @@ SOURCES += src/AboutDialog.cpp \
+ src/UiGuiSettingsDialog.cpp \
+ src/UiGuiSystemInfo.cpp \
+ src/UiGuiVersion.cpp \
+- src/UpdateCheckDialog.cpp \
+ src/debugging/TSLogger.cpp
+
+ RESOURCES += resources/Icons.qrc
+diff --git a/src/MainWindow.cpp b/src/MainWindow.cpp
+index f7b6185..f0f5251 100755
+--- a/src/MainWindow.cpp
++++ b/src/MainWindow.cpp
+@@ -31,7 +31,6 @@
+ #include "UiGuiSettingsDialog.h"
+ #include "UiGuiHighlighter.h"
+ #include "IndentHandler.h"
+-#include "UpdateCheckDialog.h"
+
+ #include <QWidget>
+ #include <QLabel>
+@@ -90,7 +89,6 @@ MainWindow::MainWindow(QString file2OpenOnStart, QWidget *parent) : QMainWindow(
+ , _qTTranslator(NULL)
+ , _toolBarWidget(NULL)
+ , _indentHandler(NULL)
+- , _updateCheckDialog(NULL)
+ , _textEditLineColumnInfoLabel(NULL)
+ {
+ // Init of some variables.
+@@ -144,11 +142,6 @@ MainWindow::MainWindow(QString file2OpenOnStart, QWidget *parent) : QMainWindow(
+
+ updateSourceView();
+
+- // Check if a newer version is available but only if the setting for that is enabled and today not already a check has been done.
+- if ( _settings->getValueByName("CheckForUpdate").toBool() && QDate::currentDate() != _settings->getValueByName("LastUpdateCheck").toDate() ) {
+- _updateCheckDialog->checkForUpdate();
+- }
+-
+ // Enable accept dropping of files.
+ setAcceptDrops(true);
+ }
+@@ -191,8 +184,6 @@ void MainWindow::initMainWindow() {
+ // -------------------------------
+ _currentEncoding = _settings->getValueByName("encoding").toString();
+
+- _updateCheckDialog = new UpdateCheckDialog(_settings, this);
+-
+ // Register the load last file setting in the menu to the _settings object.
+ _settings->registerObjectProperty(_mainWindowForm->loadLastOpenedFileOnStartupAction, "checked", "loadLastSourceCodeFileOnStartup");
+
+@@ -207,7 +198,6 @@ void MainWindow::initMainWindow() {
+ connect( _mainWindowForm->actionSave_Source_File, SIGNAL(triggered()), this, SLOT(saveSourceFile()) );
+ connect( _mainWindowForm->actionExportPDF, SIGNAL(triggered()), this, SLOT(exportToPDF()) );
+ connect( _mainWindowForm->actionExportHTML, SIGNAL(triggered()), this, SLOT(exportToHTML()) );
+- connect( _mainWindowForm->actionCheck_for_update, SIGNAL(triggered()), _updateCheckDialog, SLOT(checkForUpdateAndShowDialog()) );
+ connect( _mainWindowForm->actionShowLog, SIGNAL(triggered()), debugging::TSLogger::getInstance(), SLOT(show()) );
+
+ // Init the menu for selecting one of the recently opened files.
+diff --git a/src/MainWindow.h b/src/MainWindow.h
+index 1205a46..06b5eea 100755
+--- a/src/MainWindow.h
++++ b/src/MainWindow.h
+@@ -29,7 +29,6 @@ class AboutDialog;
+ class AboutDialogGraphicsView;
+ class UiGuiHighlighter;
+ class IndentHandler;
+-class UpdateCheckDialog;
+ namespace Ui {
+ class ToolBarWidget;
+ class MainWindowUi;
+@@ -136,7 +135,6 @@ private:
+
+ Ui::ToolBarWidget *_toolBarWidget;
+ IndentHandler *_indentHandler;
+- UpdateCheckDialog *_updateCheckDialog;
+ QLabel *_textEditLineColumnInfoLabel;
+ };
+
+diff --git a/src/MainWindow.ui b/src/MainWindow.ui
+index 1a3cacd..13eb226 100755
+--- a/src/MainWindow.ui
++++ b/src/MainWindow.ui
+@@ -113,7 +113,6 @@
+ <property name="title">
+ <string>Help</string>
+ </property>
+- <addaction name="actionCheck_for_update"/>
+ <addaction name="actionShowLog"/>
+ <addaction name="separator"/>
+ <addaction name="actionAbout_UniversalIndentGUI"/>
+@@ -424,21 +423,6 @@
+ <string>Opens the settings dialog, to set language etc.</string>
+ </property>
+ </action>
+- <action name="actionCheck_for_update">
+- <property name="icon">
+- <iconset resource="../resources/Icons.qrc">
+- <normaloff>:/mainWindow/system-software-update.png</normaloff>:/mainWindow/system-software-update.png</iconset>
+- </property>
+- <property name="text">
+- <string>Check for update</string>
+- </property>
+- <property name="toolTip">
+- <string>Checks online whether a new version of UniversalIndentGUI is available.</string>
+- </property>
+- <property name="statusTip">
+- <string>Checks online whether a new version of UniversalIndentGUI is available.</string>
+- </property>
+- </action>
+ <action name="actionClear_Recently_Opened_List">
+ <property name="icon">
+ <iconset resource="../resources/Icons.qrc">
+diff --git a/src/UiGuiSettings.cpp b/src/UiGuiSettings.cpp
+index 3aacf1f..5645d93 100755
+--- a/src/UiGuiSettings.cpp
++++ b/src/UiGuiSettings.cpp
+@@ -180,10 +180,6 @@ bool UiGuiSettings::initSettings()
+ // Read the last selected language and stores the index it has in the list of available translations.
+ _qsettings->setValue( "UniversalIndentGUI/language", _availableTranslations.indexOf( _qsettings->value("UniversalIndentGUI/language", "").toString() ) );
+
+- // Read the update check settings from the settings file.
+- _qsettings->setValue( "UniversalIndentGUI/CheckForUpdate", _qsettings->value("UniversalIndentGUI/CheckForUpdate", true) );
+- _qsettings->setValue( "UniversalIndentGUI/LastUpdateCheck", _qsettings->value("UniversalIndentGUI/LastUpdateCheck", QDate(1900,1,1)) );
+-
+ // Read the main window state.
+ _qsettings->setValue( "UniversalIndentGUI/MainWindowState", _qsettings->value("UniversalIndentGUI/MainWindowState", QByteArray()) );
+
+diff --git a/src/UiGuiSettingsDialog.ui b/src/UiGuiSettingsDialog.ui
+index e3c5f7a..2aae362 100755
+--- a/src/UiGuiSettingsDialog.ui
++++ b/src/UiGuiSettingsDialog.ui
+@@ -294,22 +294,6 @@
+ </attribute>
+ <layout class="QVBoxLayout" name="verticalLayout">
+ <item>
+- <widget class="QCheckBox" name="checkForUpdateCheckBox">
+- <property name="toolTip">
+- <string>Checks whether a new version of UniversalIndentGUI exists on program start, but only once a day.</string>
+- </property>
+- <property name="text">
+- <string>Check online for update on program start</string>
+- </property>
+- <property name="connectedSettingName" stdset="0">
+- <string notr="true">CheckForUpdate</string>
+- </property>
+- <property name="connectedPropertyName" stdset="0">
+- <string notr="true">checked</string>
+- </property>
+- </widget>
+- </item>
+- <item>
+ <widget class="QGroupBox" name="groupBox">
+ <property name="title">
+ <string/>
diff --git a/universalindentgui.desktop b/universalindentgui.desktop
new file mode 100644
index 000000000000..930bba14da98
--- /dev/null
+++ b/universalindentgui.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Name=UniversalIndentGUI
+GenericName=Code Formatter
+Comment=A cross platform GUI for several code formatters
+Exec=universalindentgui %F
+Terminal=false
+Type=Application
+Icon=universalindentgui
+StartupNotify=true
+Categories=GTK;Development;
diff --git a/universalindentgui.png b/universalindentgui.png
new file mode 100644
index 000000000000..001d69d75baa
--- /dev/null
+++ b/universalindentgui.png
Binary files differ