summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD9
-rw-r--r--qscintilla.patch11
3 files changed, 23 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d0ede2617306..c38ff0c9c308 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
-# Generated by makepkg 4.2.1
-# Tue Mar 17 01:05:05 UTC 2015
+# Generated by mksrcinfo v8
+# Sat Apr 29 01:47:08 UTC 2017
pkgbase = universalindentgui-svn
pkgdesc = A GUI for GNU Indent, Uncrustify, Artistic Styler, PHP Stylist, Ruby Beautify, HTML Tidy and many other
pkgver = r1077
@@ -10,9 +10,9 @@ pkgbase = universalindentgui-svn
license = GPL
makedepends = subversion
depends = qt4
- depends = qscintilla
+ depends = qscintilla-qt4
optdepends = astyle: a free, fast and small automatic formatter for C, C++, C# and Java,
- optdepends = ident: the GNU pretty-printer,
+ optdepends = indent: the GNU pretty-printer,
optdepends = tidyhtml: a tool to tidy down your HTML code,
optdepends = uncrustify: source code beautifier for C-like languages
optdepends = ruby: needed for some scripts
@@ -25,11 +25,13 @@ pkgbase = universalindentgui-svn
source = universalindentgui.png
source = noupdatecheck.patch
source = fix_about_dialog.patch
+ source = qscintilla.patch
sha256sums = SKIP
sha256sums = e6ed8674345d76c1f3e5ab4d6f23b64bfa7ba77141436ff325d72a28cb672a06
sha256sums = cc01fcc94cc2067e499b15189a2ac56a901562218951bd77650cf8f81bcf440d
sha256sums = b5b4d6b5604fbaaa8578a97e3a59c709bb0e1861ffaae1add3ca4452c76b5686
sha256sums = 254e237064e8422b4d219fadfaa8486a5a69b3561b8aa81df8faf3c13272e7c5
+ sha256sums = a06a47f5a9abbb4dded6fc2977c257fa99eec348805cc27f9b93793d42fdd422
pkgname = universalindentgui-svn
diff --git a/PKGBUILD b/PKGBUILD
index 03f860f3c59b..84e7e2a1924f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,11 +10,11 @@ arch=('i686' 'x86_64')
license=('GPL')
provides=('universalindentgui')
conflicts=('universalindentgui')
-depends=('qt4' 'qscintilla')
+depends=('qt4' 'qscintilla-qt4')
makedepends=('subversion')
optdepends=(
'astyle: a free, fast and small automatic formatter for C, C++, C# and Java',
- 'ident: the GNU pretty-printer',
+ 'indent: the GNU pretty-printer',
'tidyhtml: a tool to tidy down your HTML code',
'uncrustify: source code beautifier for C-like languages'
'ruby: needed for some scripts'
@@ -28,13 +28,15 @@ source=("$_svnmod::svn://svn.code.sf.net/p/universalindent/code/trunk"
"universalindentgui.png"
"noupdatecheck.patch"
"fix_about_dialog.patch"
+ "qscintilla.patch"
)
sha256sums=('SKIP'
'e6ed8674345d76c1f3e5ab4d6f23b64bfa7ba77141436ff325d72a28cb672a06'
'cc01fcc94cc2067e499b15189a2ac56a901562218951bd77650cf8f81bcf440d'
'b5b4d6b5604fbaaa8578a97e3a59c709bb0e1861ffaae1add3ca4452c76b5686'
- '254e237064e8422b4d219fadfaa8486a5a69b3561b8aa81df8faf3c13272e7c5')
+ '254e237064e8422b4d219fadfaa8486a5a69b3561b8aa81df8faf3c13272e7c5'
+ 'a06a47f5a9abbb4dded6fc2977c257fa99eec348805cc27f9b93793d42fdd422')
prepare() {
cd ${srcdir}
@@ -46,6 +48,7 @@ prepare() {
#patch -Np1 -i ../../no-strip.patch src/UniversalIndentGUI.pro #disable QT stripping
patch -p1 -i ../noupdatecheck.patch
patch -p1 -i ../fix_about_dialog.patch
+ patch -p1 -i ../qscintilla.patch
}
pkgver() {
diff --git a/qscintilla.patch b/qscintilla.patch
new file mode 100644
index 000000000000..dd6d82f8099d
--- /dev/null
+++ b/qscintilla.patch
@@ -0,0 +1,11 @@
+--- a/UniversalIndentGUI.pro
++++ b/UniversalIndentGUI.pro
+@@ -23,7 +23,7 @@
+ ICON = resources/UniversalIndentGUI.icns
+ }
+ else {
+- LIBS += -lqscintilla2
++ LIBS += -lqscintilla2_qt4
+ }
+
+ CONFIG(release, debug|release) {