summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD34
2 files changed, 29 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5207d7754451..ea8c64c80b73 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,14 @@
pkgbase = unnethack
pkgdesc = Variant of NetHack. It features more randomness, more levels, more challenges and more fun than vanilla NetHack.
- pkgver = 5.1.0
- pkgrel = 2
- url = http://sourceforge.net/apps/trac/unnethack/
+ pkgver = 5.2.0
+ pkgrel = 1
+ url = https://unnethack.wordpress.com
arch = i686
arch = x86_64
license = custom
depends = bash
- source = http://sourceforge.net/projects/unnethack/files/unnethack/5.1.0/unnethack-5.1.0-20131208.tar.gz
- md5sums = 8a5b925aedc3b7379b6adacc0f0b5915
+ source = https://github.com/UnNetHack/UnNetHack/archive/5.2.0.tar.gz
+ sha256sums = a5b2577d0caa721d0c9107c084e64ebb58041bc931c3f53f2fb02e70862d1232
pkgname = unnethack
diff --git a/PKGBUILD b/PKGBUILD
index b82e48a06202..c5e2761f69e2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,27 +2,41 @@
# Contributor: Joshua Hunt <snark1994 at gmail dot com>
# Contributor: Joao Cordeiro <jlcordeiro at gmail dot com>
pkgname=unnethack
-pkgver=5.1.0
-_pkgverdate=20131208
-pkgrel=2
+pkgver=5.2.0
+pkgrel=1
pkgdesc="Variant of NetHack. It features more randomness, more levels, more challenges and more fun than vanilla NetHack."
arch=('i686' 'x86_64')
-url="http://sourceforge.net/apps/trac/unnethack/"
+url="https://unnethack.wordpress.com"
license=('custom')
depends=('bash')
-source=(http://sourceforge.net/projects/$pkgname/files/$pkgname/$pkgver/$pkgname-$pkgver-$_pkgverdate.tar.gz)
-md5sums=('8a5b925aedc3b7379b6adacc0f0b5915')
+source=(https://github.com/UnNetHack/UnNetHack/archive/$pkgver.tar.gz)
+sha256sums=('a5b2577d0caa721d0c9107c084e64ebb58041bc931c3f53f2fb02e70862d1232')
+
+prepare() {
+ cd "$srcdir/UnNetHack-$pkgver"
+ sed -e "s/GAMEUID = @OWNER@/GAMEUID = root/g" \
+ -e "s/GAMEGRP = @GROUP@/GAMEGRP = games/g" \
+ -e "s/GAMEPERM = 04755/GAMEPERM = 02775/g" \
+ -e "s/VARFILEPERM = 0644/VARFILEPERM = 0664/g" \
+ -e "s/VARDIRPERM = 0755/VARDIRPERM = 0775/g" -i sys/autoconf/Makefile.top
+}
build() {
- cd "$srcdir/$pkgname-$pkgver-$_pkgverdate"
+ cd "$srcdir/UnNetHack-$pkgver"
- ./configure --bindir=/usr/bin --prefix=/usr/share/unnethack --with-owner=`id -un` --with-group=`id -gn` --enable-wizmode=`id -un` --enable-curses-graphics
+ ./configure --prefix=/usr --with-gamesdir=/var/games/unnethack --with-owner=`id -un` --enable-curses-graphics
make
}
package(){
- cd "$srcdir/$pkgname-$pkgver-$_pkgverdate"
+ cd "$srcdir/UnNetHack-$pkgver"
make DESTDIR="$pkgdir" install
- install -D -m 644 dat/license $pkgdir/usr/share/licenses/$pkgname/license
+ make DESTDIR="$pkgdir" install manpages
+
+ chown -R root:root "$pkgdir/usr/"
+ chown root:games "$pkgdir/usr/share/unnethack/unnethack"
+ chmod 775 "$pkgdir/var/games/"
+
+ install -D -m 644 dat/license "$pkgdir/usr/share/licenses/$pkgname/license"
}