summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD4
-rw-r--r--ignore-return-value-error.patch15
3 files changed, 16 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 385d39d137f5..73a14da1776e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Mon Mar 20 18:22:27 UTC 2017
+# Sun Apr 23 18:45:28 UTC 2017
pkgbase = unreal-engine
pkgdesc = A 3D game engine by Epic Games which can be used non-commercially for free.
pkgver = 4.15.1
@@ -25,7 +25,7 @@ pkgbase = unreal-engine
md5sums = SKIP
md5sums = c7fc35a7eb9e23c0a9b7c593f7f9878d
md5sums = 271579e814358390d210d57c724a3b00
- md5sums = 183ca1792f46a21461ed6f4c6d621a37
+ md5sums = a5bb2f9ebc7379b603e3293880dc5c12
pkgname = unreal-engine
diff --git a/PKGBUILD b/PKGBUILD
index 25946f8196ca..20be5f636557 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -27,7 +27,7 @@ md5sums=(
'SKIP'
'c7fc35a7eb9e23c0a9b7c593f7f9878d'
'271579e814358390d210d57c724a3b00'
- '183ca1792f46a21461ed6f4c6d621a37'
+ 'a5bb2f9ebc7379b603e3293880dc5c12'
)
prepare() {
@@ -86,7 +86,7 @@ package() {
cp -r Engine/Saved "$pkgdir/opt/$pkgname/Engine/Saved"
cp -r Engine/Shaders "$pkgdir/opt/$pkgname/Engine/Shaders"
cp -r Engine/Source "$pkgdir/opt/$pkgname/Engine/Source" # the source cannot be redistributed, but seems to be needed to compile c++ projects
-
+
# these folders needs to be writable, otherwise there is a segmentation fault when starting the editor
chmod -R a+rwX "$pkgdir/opt/$pkgname/Engine"
diff --git a/ignore-return-value-error.patch b/ignore-return-value-error.patch
index 5d2faf08dc8e..769a2ef44aa1 100644
--- a/ignore-return-value-error.patch
+++ b/ignore-return-value-error.patch
@@ -1,6 +1,15 @@
---- Engine/Source/Programs/UnrealBuildTool/Linux/LinuxToolChain.cs.old 2017-01-04 13:45:29.669145563 -0500
-+++ Engine/Source/Programs/UnrealBuildTool/Linux/LinuxToolChain.cs 2017-01-04 13:45:34.875764475 -0500
-@@ -393,6 +393,8 @@
+--- ./src/UnrealEngine/Engine/Source/Programs/UnrealBuildTool/Linux/LinuxToolChain.cs.orig 2017-04-23 13:59:57.476068918 -0400
++++ ./src/UnrealEngine/Engine/Source/Programs/UnrealBuildTool/Linux/LinuxToolChain.cs 2017-04-23 14:42:48.021739418 -0400
+@@ -94,7 +94,7 @@
+ throw new BuildException("clang 3.4.x is known to miscompile the engine - refusing to register the Linux toolchain.");
+ }
+ // prevent unknown clangs since the build is likely to fail on too old or too new compilers
+- else if ((CompilerVersionMajor * 10 + CompilerVersionMinor) > 39 || (CompilerVersionMajor * 10 + CompilerVersionMinor) < 35)
++ else if ((CompilerVersionMajor * 10 + CompilerVersionMinor) > 40 || (CompilerVersionMajor * 10 + CompilerVersionMinor) < 35)
+ {
+ throw new BuildException(
+ string.Format("This version of the Unreal Engine can only be compiled with clang 3.9, 3.8, 3.7, 3.6 and 3.5. clang {0} may not build it - please use a different version.",
+@@ -387,6 +387,8 @@
Result += " -Wno-unused-variable";
// this will hide the warnings about static functions in headers that aren't used in every single .cpp file
Result += " -Wno-unused-function";