summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PKGBUILD5
1 files changed, 4 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d3bc21567d9f..a1a1e4d9c41f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -26,11 +26,14 @@ options=(!strip staticlibs)
build() {
cd $srcdir/UnrealEngine
+
+ # clean up old build, otherwise there are errors building a new version in same dir
+ git clean -xdf
./Setup.sh
./GenerateProjectFiles.sh
- # needed to build a different version in the same build dir
+ # this should work instead of "git clean", but something leftover causes crashes
#make ARGS=-clean
make