summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--0002-remove-clang35-dependency.patch19
-rw-r--r--PKGBUILD9
3 files changed, 32 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 14b071f7f58a..44f8618792b1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Thu Sep 1 22:25:51 UTC 2016
+# Sat Sep 3 17:52:37 UTC 2016
pkgbase = unreal-engine
pkgdesc = A 3D game engine by Epic Games which can be used non-commercially for free.
- pkgver = 4.13.1
+ pkgver = 4.13.0
pkgrel = 1
url = https://www.unrealengine.com/
arch = x86_64
@@ -18,12 +18,14 @@ pkgbase = unreal-engine
depends = python
options = !strip
options = staticlibs
- source = git+ssh://git@github.com/EpicGames/UnrealEngine.git#tag=4.13.1-release
+ source = git+ssh://git@github.com/EpicGames/UnrealEngine.git#tag=4.13.0-release
source = UE4Editor.desktop
source = 0001-ignore-return-value-error.patch
+ source = 0002-remove-clang35-dependency.patch
md5sums = SKIP
md5sums = c7fc35a7eb9e23c0a9b7c593f7f9878d
md5sums = 08e0e6b8e6c9b186191a8419cc7bd435
+ md5sums = 604094f337176251bcfdacd3a21aa081
pkgname = unreal-engine
diff --git a/0002-remove-clang35-dependency.patch b/0002-remove-clang35-dependency.patch
new file mode 100644
index 000000000000..c8bd55bc8795
--- /dev/null
+++ b/0002-remove-clang35-dependency.patch
@@ -0,0 +1,19 @@
+commit 9a991321e930899fe555b6182064f3d5b8b81d73
+Author: acerix <dylan@psilly.com>
+Date: Sat Sep 3 13:45:02 2016 -0400
+
+ remove clang35 dependency
+
+diff --git a/Engine/Build/BatchFiles/Linux/Setup.sh b/Engine/Build/BatchFiles/Linux/Setup.sh
+index 787bfef..4d649e8 100755
+--- a/Engine/Build/BatchFiles/Linux/Setup.sh
++++ b/Engine/Build/BatchFiles/Linux/Setup.sh
+@@ -125,7 +125,7 @@ if [ -e /etc/os-release ]; then
+
+ # Arch Linux
+ if [[ "$ID" == "arch" ]] || [[ "$ID_LIKE" == "arch" ]]; then
+- DEPS="clang35 mono python sdl2 qt4 dos2unix cmake"
++ DEPS="clang mono python sdl2 qt4 dos2unix cmake"
+ MISSING=false
+ for DEP in $DEPS; do
+ if ! pacman -Qs $DEP > /dev/null 2>&1; then
diff --git a/PKGBUILD b/PKGBUILD
index 5c70e07094c0..78653eed778f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
# The source is about 3.78 GiB, with an extra 3.24 GiB of dependencies downloaded in build(), and may take several hours to compile. (sizes as of 4.12)
pkgname='unreal-engine'
-pkgver=4.13.1
+pkgver=4.13.0
pkgrel=1
pkgdesc='A 3D game engine by Epic Games which can be used non-commercially for free.'
arch=('x86_64')
@@ -18,16 +18,19 @@ source=(
"git+ssh://git@github.com/EpicGames/UnrealEngine.git#tag=$pkgver-release"
'UE4Editor.desktop'
'0001-ignore-return-value-error.patch'
+ '0002-remove-clang35-dependency.patch'
)
md5sums=(
'SKIP'
'c7fc35a7eb9e23c0a9b7c593f7f9878d'
'08e0e6b8e6c9b186191a8419cc7bd435'
+ '604094f337176251bcfdacd3a21aa081'
)
options=(!strip staticlibs)
build() {
patch "$srcdir/UnrealEngine/Engine/Source/Programs/UnrealBuildTool/Linux/LinuxToolChain.cs" 0001-ignore-return-value-error.patch
+ patch "$srcdir/UnrealEngine/Engine/Build/BatchFiles/Linux/Setup.sh" 0002-remove-clang35-dependency.patch
cd $srcdir/UnrealEngine
@@ -75,6 +78,10 @@ package() {
cp -r Samples "$pkgdir/opt/$pkgname/Samples"
cp -r Templates "$pkgdir/opt/$pkgname/Templates"
+ # build scripts, used by some plugins
+ install -Dm755 GenerateProjectFiles.sh "$pkgdir/opt/$pkgname/GenerateProjectFiles.sh"
+ install -Dm755 Setup.sh "$pkgdir/opt/$pkgname/Setup.sh"
+
# icon for .desktop file
install -Dm644 Engine/Source/Programs/UnrealVS/Resources/Preview.png "$pkgdir/usr/share/pixmaps/UE4Editor.png"
}