summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD27
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..396d3fef24f4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = unsilence
+ pkgdesc = Console Interface and Library to remove silent parts of a media file
+ pkgver = 1.0.3
+ pkgrel = 1
+ url = https://github.com/lagmoellertim/unsilence
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ depends = ffmpeg
+ depends = python-argparse
+ depends = python-rich
+ source = https://github.com/lagmoellertim/unsilence/archive/1.0.3.tar.gz
+ sha256sums = ac9ea5b5b5a8743133b4fd11fcc2b51418756e2d53530c71c0f663f44e24a56f
+
+pkgname = unsilence
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7fb384a3140a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Caltlgin Stsodaat <contact@fossdaily.xyz>
+
+pkgname=unsilence
+pkgver=1.0.3
+pkgrel=1
+pkgdesc='Console Interface and Library to remove silent parts of a media file'
+arch=('any')
+url='https://github.com/lagmoellertim/unsilence'
+license=('MIT')
+depends=('ffmpeg' 'python-argparse' 'python-rich')
+makedepends=('python-setuptools')
+source=("${url}/archive/${pkgver}.tar.gz")
+sha256sums=('ac9ea5b5b5a8743133b4fd11fcc2b51418756e2d53530c71c0f663f44e24a56f')
+
+build() {
+ cd "${pkgname}-${pkgver}"
+ python setup.py build
+}
+
+package() {
+ cd "${pkgname}-${pkgver}"
+ python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+ install -Dm644 'README.md' "${pkgdir}/usr/share/doc/${pkgname}/README.md"
+ install -Dm644 'LICENSE' "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
+
+# vim: ts=2 sw=2 et: