summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD63
-rw-r--r--upak.install31
3 files changed, 40 insertions, 65 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8d82aaaac84c..d7de417f2dde 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,7 @@
-# Generated by mksrcinfo v8
-# Wed Jun 26 14:43:21 UTC 2019
pkgbase = upak
pkgdesc = HRIBF Data Acquisition and analysis.
pkgver = 10.6.8
- pkgrel = 9
+ pkgrel = 10
url = ftp://ftp.phy.ornl.gov/pub/upak/README.html
install = upak.install
arch = x86_64
@@ -14,10 +12,9 @@ pkgbase = upak
depends = bash
options = staticlibs
options = emptydirs
- source = ftp://ftp.phy.ornl.gov/pub/upak/upak-src.tgz
+ source = https://ftp.phy.ornl.gov/fauxtp/upak/upak-src.tgz
source = upak.install
- md5sums = 6fda860ff33eda39c2914f34453ce96b
- md5sums = 7d8e9e7ec0f6ed54683a65f640899e20
+ md5sums = e41040fe104b97be91697b94a78bcdee
+ md5sums = 8f74428b994ee5000ece375945b65171
pkgname = upak
-
diff --git a/PKGBUILD b/PKGBUILD
index b2ab7ceeecc4..546aab459f15 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,9 @@
# Maintainer: Luis Sarmiento <Luis.Sarmiento-ala-nuclear.lu.se>
+# Co-Maintainer: effeffe - Filippo Falezza <filippo dot falezza at outlook dot com>
pkgname=upak
pkgver=10.6.8 # <-- current source doesn't have a version. We keep the last known one
-pkgrel=9
+pkgrel=10
pkgdesc="HRIBF Data Acquisition and analysis."
url="ftp://ftp.phy.ornl.gov/pub/upak/README.html"
arch=('x86_64')
@@ -10,48 +11,32 @@ license=('unknown')
depends=('libx11' 'tcsh' 'bash')
makedepends=('gcc-fortran>=4.2')
options=(staticlibs emptydirs)
-source=("ftp://ftp.phy.ornl.gov/pub/${pkgname}/${pkgname}-src.tgz"
+source=(
+ "https://ftp.phy.ornl.gov/fauxtp/${pkgname}/${pkgname}-src.tgz"
"upak.install")
-md5sums=('6fda860ff33eda39c2914f34453ce96b'
- '7d8e9e7ec0f6ed54683a65f640899e20')
-
+md5sums=(
+ 'e41040fe104b97be91697b94a78bcdee'
+ '8f74428b994ee5000ece375945b65171')
install="${pkgname}.install"
-package() {
-
- ## compile
- cd "${srcdir}/${pkgname}"
+package(){
+ cd ${srcdir}
make clean
- make -j1 INSTALLDIR="${pkgdir}/usr/bin" all # <-- this already goes to ${pkgdir} therefore must be package() not build()
-
- ## documentation (0)
- _DOCDIR=${pkgdir}/usr/share/doc/${pkgname}
- [ -d ${_DOCDIR} ] || install -d ${_DOCDIR}
-
- # correct the location of the doc dir and change executable permissions
- install -m644 ${pkgdir}/usr/bin/doc/* ${_DOCDIR}
- rm -rf ${pkgdir}/usr/bin/doc
-
- # correct the location of the file and create DOC dir
- install -Dm644 ${pkgdir}/usr/bin/*.{hep,ps,dat,make,f} ${_DOCDIR}
-
- #clean bin directory from what is already placed in the doc dir.
- rm -f ${pkgdir}/usr/bin/*.{hep,ps,dat,make,f}
-
- ## libraries
- _LIBDIR=${pkgdir}/usr/lib
- [ -d ${_LIBDIR} ] || install -d ${_LIBDIR}
-
- install -Dm644 ${pkgdir}/usr/bin/*.{a,o} ${pkgdir}/usr/lib/
-
- #clean bin directory from what is already placed in the lib dir.
- rm -f ${pkgdir}/usr/bin/*.{a,o}
-
- ## others
- cd "${srcdir}/${pkgname}"
- install -m644 Dreadme/README-Apr07 ${_DOCDIR}
- install -m644 Dreadme/readme.{tex,doc} ${_DOCDIR}
- install -m644 Dreadme/dvd.{tex,doc} ${_DOCDIR}
+ make -j1 INSTALLDIR="${pkgdir}/usr/local/hhirf" all # <-- this already goes to ${pkgdir} therefore must be package() not build()
+
+ cd ${srcdir}
+ install -m644 Dreadme/README-Apr07 $pkgdir/usr/local/hhirf/doc
+ install -m644 Dreadme/readme.{tex,doc} $pkgdir/usr/local/hhirf/doc
+ install -m644 Dreadme/dvd.{tex,doc} $pkgdir/usr/local/hhirf/doc
+
+ cd $pkgdir/usr/local/hhirf
+ for file in $(ls doc/*.doc);do
+ file=$(basename -s .doc $file)
+ ./txx doc/$file x
+ ./txxps $file
+ rm $file.txx
+ mv $file.ps doc/
+ done
}
diff --git a/upak.install b/upak.install
index dfe818bae444..a11fe1135421 100644
--- a/upak.install
+++ b/upak.install
@@ -1,24 +1,17 @@
#!/bin/sh
-
-post_upgrade() {
- _help_warning
-
-}
-
post_install() {
- _help_warning
-}
-
-_help_warning() {
- cat <<EOF
->>> NOTE: Remember to set properly your help path. By default upak is expecting the
->>> help to be located in /usr/hhirf/damm.hep or to be pointed out in explicitly
->>> in the file: \${HOME}/upak_help_path.
->>>
->>> You can set your help path by typing in a terminal the following:
->>>
->>> echo "/usr/share/doc/upak/" > \${HOME}/upak_help_path
->>>
+ if [ -z $SUDO_USER ]; then
+ if [ $SUDO_USER=root ]; then
+ echo "/usr/local/hhirf/upak/doc" > \/root/upak_help_path
+ else
+ cat <<EOF
+>>> please create a file in your home directory named 'upak_help_path' containing
+>>> /usr/local/hhirf/upak/doc
EOF
+ fi
+ else
+ echo "/usr/local/hhirf/upak/doc" > \/home/${SUDO_USER}/upak_help_path
+ fi
+
}