aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--0003-usd-python.patch27
-rw-r--r--PKGBUILD15
-rw-r--r--upbge.desktop10
4 files changed, 7 insertions, 51 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ba82e03bb436..37a690b606f5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = upbge-git
pkgdesc = Uchronia Project Blender Game Engine fork of Blender Game Engine
- pkgver = 137410.f523c32ec73
+ pkgver = 142060.aa50f945acc
pkgrel = 1
url = https://upbge.org/
arch = i686
@@ -64,9 +64,7 @@ pkgbase = upbge-git
source = blender/translations::git+https://github.com/blender/blender-translations
source = blender/dev_tools::git+https://github.com/blender/blender-dev-tools
source = blender/assets::svn+https://svn.blender.org/svnroot/bf-blender/trunk/lib/assets
- source = upbge.desktop
source = 0001-use-github.com-for-make-update-git.patch
- source = 0003-usd-python.patch
source = 0004-fix-opencollada-pcre.patch
sha256sums = SKIP
sha256sums = SKIP
@@ -74,9 +72,7 @@ pkgbase = upbge-git
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
- sha256sums = b5c9bf4fa265389db4b3f23e96d74cc86c51d908b8943eb80967614d8af1ea1a
sha256sums = 0bb8ac4cba0ac00999790087c51e601d185b78a96081f08a7c7afb8c0f4b0d7c
- sha256sums = c2db51a83a8d573aa76c760f10e541c84b108d64d05c9647681c4e633b3d0397
sha256sums = 6beedc541e33288a282f57cd2bd09860f333154027b6175e9f61cce49b8db5df
pkgname = upbge-git
diff --git a/0003-usd-python.patch b/0003-usd-python.patch
deleted file mode 100644
index e0537d8cb921..000000000000
--- a/0003-usd-python.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-diff --git a/build_files/cmake/platform/platform_unix.cmake b/build_files/cmake/platform/platform_unix.cmake
-index 787d0f87002..659938a45b2 100644
---- a/build_files/cmake/platform/platform_unix.cmake
-+++ b/build_files/cmake/platform/platform_unix.cmake
-@@ -329,6 +329,10 @@ if(WITH_OPENVDB)
- endif()
- add_bundled_libraries(openvdb/lib)
-
-+if(WITH_USD)
-+ list(APPEND __boost_packages python)
-+endif()
-+
- if(WITH_NANOVDB)
- find_package_wrapper(NanoVDB)
- set_and_warn_library_found("NanoVDB" NANOVDB_FOUND WITH_NANOVDB)
-diff --git a/source/blender/io/usd/CMakeLists.txt b/source/blender/io/usd/CMakeLists.txt
-index ebd292782c0..02486e72461 100644
---- a/source/blender/io/usd/CMakeLists.txt
-+++ b/source/blender/io/usd/CMakeLists.txt
-@@ -55,6 +55,7 @@ set(INC
- set(INC_SYS
- ${USD_INCLUDE_DIRS}
- ${BOOST_INCLUDE_DIR}
-+ ${PYTHON_INCLUDE_DIRS}
- ${TBB_INCLUDE_DIR}
- ${PYTHON_INCLUDE_DIR}
- )
diff --git a/PKGBUILD b/PKGBUILD
index 046c1327b7e9..2099e39b8515 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,7 +12,7 @@
_fragment="${FRAGMENT:-#branch=master}"
pkgname=upbge-git
-pkgver=137410.f523c32ec73
+pkgver=142060.aa50f945acc
pkgrel=1
pkgdesc="Uchronia Project Blender Game Engine fork of Blender Game Engine"
arch=('i686' 'x86_64')
@@ -46,10 +46,8 @@ source=("upbge::git+https://github.com/UPBGE/upbge${_fragment}"
'blender/translations::git+https://github.com/blender/blender-translations'
'blender/dev_tools::git+https://github.com/blender/blender-dev-tools'
'blender/assets::svn+https://svn.blender.org/svnroot/bf-blender/trunk/lib/assets'
- upbge.desktop
# Patches...
'0001-use-github.com-for-make-update-git.patch'
- '0003-usd-python.patch' #add missing python headers when building against python enabled usd.
'0004-fix-opencollada-pcre.patch' #fix broken search for opencollada pcre
)
sha256sums=('SKIP'
@@ -58,9 +56,7 @@ sha256sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
- 'b5c9bf4fa265389db4b3f23e96d74cc86c51d908b8943eb80967614d8af1ea1a'
'0bb8ac4cba0ac00999790087c51e601d185b78a96081f08a7c7afb8c0f4b0d7c'
- 'c2db51a83a8d573aa76c760f10e541c84b108d64d05c9647681c4e633b3d0397'
'6beedc541e33288a282f57cd2bd09860f333154027b6175e9f61cce49b8db5df')
pkgver() {
@@ -99,7 +95,8 @@ build() {
export CUDAHOSTCXX="$CC"
_CMAKE_FLAGS+=( -DWITH_CLANG=ON \
- -DWITH_CYCLES=ON )
+ -DWITH_CYCLES=ON \
+ -DCMAKE_LINKER_TYPE=BFD )
# Use CUDA_ARCH to build for specific GPU architecture
# Supports: single arch (sm_52) and list of archs (sm_52;sm_60)
@@ -236,9 +233,9 @@ package() {
fi
install -D -m755 "$srcdir"/build/bin/blenderplayer "$pkgdir"/usr/bin/blenderplayer
- install -D -m644 "$srcdir"/upbge.desktop "$pkgdir"/usr/share/applications/upbge.desktop
- install -D -m644 "$srcdir"/upbge/release/freedesktop/icons/scalable/apps/upbge.svg \
- "$pkgdir"/usr/share/icons/hicolor/scalable/apps/upbge.svg
+ install -D -m644 "$srcdir"/upbge/release/freedesktop/org.upbge.UPBGE.desktop "$pkgdir"/usr/share/applications/org.upbge.UPBGE.desktop
+ install -D -m644 "$srcdir"/upbge/release/freedesktop/icons/scalable/apps/org.upbge.UPBGE.svg \
+ "$pkgdir"/usr/share/icons/hicolor/scalable/apps/org.upbge.UPBGE.svg
}
# vim: syntax=bash:et:ts=2:sw=2
diff --git a/upbge.desktop b/upbge.desktop
deleted file mode 100644
index c93e56d414cf..000000000000
--- a/upbge.desktop
+++ /dev/null
@@ -1,10 +0,0 @@
-[Desktop Entry]
-Name=UPBGE
-Comment=Uchronia Project Blender Game Engine
-Exec=blender
-Icon=upbge
-Terminal=false
-X-MultipleArgs=false
-Type=Application
-Categories=Graphics;3DGraphics;
-MimeType=application/blender;application/x-blender;