summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD17
2 files changed, 16 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 70912826df54..b73dfe93a055 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -5,9 +5,11 @@ pkgbase = upcheck
url = https://gitlab.com/edu4rdshl/upcheck
arch = x86_64
license = GPL3
+ makedepends = git
+ makedepends = cargo
depends = pacman-contrib
- source = https://gitlab.com/edu4rdshl/upcheck/-/archive/0.1.3/upcheck-0.1.3.tar.gz
- sha512sums = 38e14ef4910c9afb2858d70a1663dd5fed8f13256240a6d6761e881d943f6dd95bbb46830f568bb60fe2dba822ec3a82741fa058475acc9534746ec0cf149957
+ source = git+https://github.com/Edu4rdSHL/upcheck.git
+ sha512sums = SKIP
pkgname = upcheck
diff --git a/PKGBUILD b/PKGBUILD
index a2ffe858f9a6..96bae4493428 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,13 +8,20 @@ arch=('x86_64')
url='https://gitlab.com/edu4rdshl/upcheck'
license=('GPL3')
depends=('pacman-contrib')
-source=("https://gitlab.com/edu4rdshl/${pkgname}/-/archive/${pkgver}/${pkgname}-${pkgver}.tar.gz")
-sha512sums=('38e14ef4910c9afb2858d70a1663dd5fed8f13256240a6d6761e881d943f6dd95bbb46830f568bb60fe2dba822ec3a82741fa058475acc9534746ec0cf149957')
+makedepends=('git' 'cargo')
+source=("git+https://github.com/Edu4rdSHL/$pkgname.git")
+sha512sums=('SKIP')
+
+build() {
+ cd $pkgname
+
+ cargo build --release --locked
+}
package() {
cd "${pkgname}-${pkgver}"
- install -Dm 755 bin/"${pkgname}" "${pkgdir}/usr/bin/${pkgname}"
- install -Dm 755 README.md "${pkgdir}/usr/share/doc/${pkgname}/README"
- install -Dm 644 "${pkgname}".service "${pkgdir}/usr/lib/systemd/user/${pkgname}.service"
+ install -Dm 755 "target/release/$pkgname" "$pkgdir/usr/bin/$pkgname"
+ install -Dm 755 README.md "$pkgdir/usr/share/doc/$pkgname/README"
+ install -Dm 644 "$pkgname.service" "$pkgdir/usr/lib/systemd/user/$pkgname.service"
}