summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD16
2 files changed, 13 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 149e1b686531..cfb2e1325317 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,23 +1,22 @@
pkgbase = update-notifier
pkgdesc = A simple pacman update notifier
pkgver = 0.7.7
- pkgrel = 4
+ pkgrel = 5
url = https://github.com/Chrysostomus/update-notifier
arch = any
- license = MIT
+ license = custom:MIT
makedepends = git
depends = awk
depends = dunst>=1.3.2-2
depends = libnotify
- depends = fakeroot
+ depends = bash
optdepends = yaourt: for AUR support
optdepends = gnome-terminal: for integration with gnome-update-notifications
optdepends = pamac: for graphical update actions
optdepends = yay: for AUR support
optdepends = trizen: for AUR support
optdepends = pacaur: for AUR support
- source = git://github.com/Chrysostomus/update-notifier
+ source = git+https://github.com/Chrysostomus/update-notifier
md5sums = SKIP
pkgname = update-notifier
-
diff --git a/PKGBUILD b/PKGBUILD
index 3e8d96c7dc4d..a09bc29db638 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,17 @@
-# Maintainer: Emilio Reggi <nag@mailbox.org>
-# Maintainer: Mubashshir <ahmubashshir@gmail.com>
+# Maintainer: Kemel Zaidan <kemelzaidan@gmail.com>
+# Contributor: Emilio Reggi <nag@mailbox.org>
+# Contributor: Mubashshir <ahmubashshir@gmail.com>
pkgname=update-notifier
pkgver=0.7.7
-pkgrel=4
+pkgrel=5
pkgdesc="A simple pacman update notifier"
arch=(any)
url="https://github.com/Chrysostomus/$pkgname"
-license=('MIT')
+license=('custom:MIT')
depends=('awk'
'dunst>=1.3.2-2'
'libnotify'
- 'fakeroot')
+ 'bash')
optdepends=('yaourt: for AUR support'
'gnome-terminal: for integration with gnome-update-notifications'
'pamac: for graphical update actions'
@@ -18,11 +19,12 @@ optdepends=('yaourt: for AUR support'
'trizen: for AUR support'
'pacaur: for AUR support')
makedepends=('git')
-source=("git://github.com/Chrysostomus/$pkgname")
+source=("git+https://github.com/Chrysostomus/$pkgname")
md5sums=('SKIP')
package () {
- cd "$srcdir"
+ cd "$srcdir"
+ install -Dm644 "$srcdir/$pkgname/LICENSE" -t "$pkgdir/usr/share/licenses/$pkgname/"
install -Dm755 "$srcdir/$pkgname/update-notifier" "$pkgdir/usr/bin/update-notifier"
install -Dm755 "$srcdir/$pkgname/update-checker" "$pkgdir/usr/bin/update-checker"
install -Dm755 "$srcdir/$pkgname/update-check" "$pkgdir/usr/bin/update-check"