summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PKGBUILD2
1 files changed, 2 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 47df2614ce05..9dca0808d8a4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -151,6 +151,8 @@ if ! :; then
-e 's:array\[:html_array\[:g' 'stringtools.cpp'
sed -i -e 's:^#define _exit exit:// &:g' 'cryptoplugin/dllmain.cpp'
fi
+ # Simple assert errors, probably fixed soon
+ sed -i -e 's:^#include "AESGCMDecryption.h".*$:#include <assert.h>\r\n&:g' 'cryptoplugin/AESGCMDecryption.cpp'
# fix the build scripts
#sed -i -e 's:response.readall():response.read():g' 'build/replace_versions.py' # python was always a bad choice for these text replacements. As of Python 3.5 this script doesn't work at all and read() is not a proper replacement for readall().