summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD52
-rw-r--r--urjtag_libftd2xx.patch20
3 files changed, 96 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..828fab2841ff
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = urjtag-git
+ pkgdesc = Enhanced, modern tool for communicating over JTAG with flash chips, CPUs,and many more
+ pkgver = r1789.7ba12da
+ pkgrel = 1
+ url = http://urjtag.org/
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ license = LGPL2.1
+ makedepends = git
+ makedepends = gcc
+ makedepends = libftd2xx
+ makedepends = flex
+ makedepends = bison
+ depends = libftd2xx
+ conflicts = urjtag
+ options = !strip
+ source = urjtag-git::git://git.code.sf.net/p/urjtag/git
+ source = urjtag_libftd2xx.patch
+ sha512sums = SKIP
+ sha512sums = c17acc473aa5c4ce849ee6404a6d17b80b9933c227fa5e33009188f2b8b51e0e2cb6778324b12aa3348ad34f8d083a8602439bdfe3ec6bb0959cb398bd8acdc9
+
+pkgname = urjtag-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e44db2d514a2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,52 @@
+# Maintainer: Andreas B. Wagner <andreas.wagner@lowfatcomputing.org>
+# Maintainer: Peter Ivanov <ivanovp@gmail.com>
+# $Id: PKGBUILD 84937 2010-07-05 17:46:04Z eric $
+# Contributor: Tobias Powalowski <tpowa@archlinux.org>
+
+_pkgname=urjtag
+pkgname=${_pkgname}-git
+pkgver=r1789.7ba12da
+pkgrel=1
+pkgdesc="Enhanced, modern tool for communicating over JTAG with flash chips, CPUs,and many more"
+arch=("i686" "x86_64")
+url="http://urjtag.org/"
+license=("GPL2" "LGPL2.1")
+depends=('libftd2xx')
+makedepends=('git' 'gcc' 'libftd2xx' 'flex' 'bison')
+#makedepends=(svn gcc flex bison)
+conflicts=('urjtag')
+options=('!strip')
+source=("$pkgname::git://git.code.sf.net/p/urjtag/git"
+ 'urjtag_libftd2xx.patch')
+sha512sums=('SKIP'
+ 'c17acc473aa5c4ce849ee6404a6d17b80b9933c227fa5e33009188f2b8b51e0e2cb6778324b12aa3348ad34f8d083a8602439bdfe3ec6bb0959cb398bd8acdc9')
+
+pkgver() {
+ cd "$srcdir/$pkgname"
+ ( set -o pipefail
+ git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+}
+
+build() {
+ cd "$srcdir/$pkgname/$_pkgname"
+# cd "$srcdir/$pkgname-$pkgver/trunk/urjtag"
+# if [ ! -f _patched ]; then
+# patch -p1 <../../urjtag_libftd2xx.patch
+# touch _patched
+# fi
+ if [ ! -f ./configure ]; then
+ ./autogen.sh
+ fi
+ ./configure --prefix=/usr
+# ./configure --prefix=/usr --without-ftd2xx
+# ./configure --prefix=/usr CFLAGS="-Wno-error=unused-but-set-variable"
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname/$_pkgname"
+ make DESTDIR="$pkgdir" install
+}
+
diff --git a/urjtag_libftd2xx.patch b/urjtag_libftd2xx.patch
new file mode 100644
index 000000000000..eb4f9a3bef8f
--- /dev/null
+++ b/urjtag_libftd2xx.patch
@@ -0,0 +1,20 @@
+--- urjtag/src/tap/usbconn/libftd2xx.c.ORIG 2011-10-31 10:00:34.746529359 +0100
++++ urjtag/src/tap/usbconn/libftd2xx.c 2011-10-31 10:03:43.009128467 +0100
+@@ -172,7 +172,7 @@
+
+ urj_log (URJ_LOG_LEVEL_COMM,
+ "%sflush end: status %ld, xferred %ld, recvd %ld\n", module,
+- status, xferred, recvd);
++ (long int) status, (long int) xferred, (long int) recvd);
+
+ return status != FT_OK ? -1 : xferred;
+ }
+@@ -225,7 +225,7 @@
+ }
+
+ urj_log (URJ_LOG_LEVEL_COMM, "%sread end : status %ld, length %d\n",
+- module, status, cpy_len + len);
++ module, (long int) status, (int) cpy_len + len);
+
+ return status != FT_OK ? -1 : cpy_len + len;
+ }