summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD18
2 files changed, 20 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6a5fc1a02c5d..23de5cb6d589 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,16 @@
pkgbase = urlcrazy
- pkgdesc = Generate and test domain typos and variations to detect and perform typo squatting, URL hijacking, phishing, and corporate espionage.
- pkgver = 0.5
- pkgrel = 3
- url = http://www.morningstarsecurity.com/research/urlcrazy
+ pkgdesc = Generate and test domain typos and variations to detect and perform typo squatting, URL hijacking, phishing, and corporate espionage
+ pkgver = 0.7.3
+ pkgrel = 1
+ url = https://github.com/urbanadventurer/urlcrazy
arch = any
license = custom
- depends = ruby
- source = http://www.morningstarsecurity.com/downloads/urlcrazy-0.5.tar.gz
- md5sums = bfe2e0c71cc5160530b773f15d242964
+ depends = ruby-json
+ depends = ruby-colorize
+ depends = ruby-async
+ depends = ruby-async-dns
+ depends = ruby-async-http
+ source = urlcrazy-0.7.3.tar.gz::https://github.com/urbanadventurer/urlcrazy/archive/refs/tags/v0.7.3.tar.gz
+ sha256sums = b04745000e2c27fd85f7b6af98bdac81b7d1685da87267fc47adea0735a42b95
pkgname = urlcrazy
-
diff --git a/PKGBUILD b/PKGBUILD
index efc5c6785109..d85d0b78b9a4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,17 @@
-# Maintainer: /dev/rs0 <rs0@secretco.de.com>
+# Contributor: Gokberk Yaltirakli <aur at gkbrk dot com>
+# Contributor: /dev/rs0 <rs0@secretco.de.com>
pkgname=urlcrazy
-pkgver=0.5
-pkgrel=3
-pkgdesc="Generate and test domain typos and variations to detect and perform typo squatting, URL hijacking, phishing, and corporate espionage."
-
+pkgver=0.7.3
+pkgrel=1
+pkgdesc="Generate and test domain typos and variations to detect and perform typo squatting, URL hijacking, phishing, and corporate espionage"
arch=('any')
license=('custom')
-url="http://www.morningstarsecurity.com/research/urlcrazy"
+url="https://github.com/urbanadventurer/urlcrazy"
+depends=('ruby-json' 'ruby-colorize' 'ruby-async' 'ruby-async-dns' 'ruby-async-http')
+source=(${pkgname}-${pkgver}.tar.gz::${url}/archive/refs/tags/v${pkgver}.tar.gz)
+sha256sums=('b04745000e2c27fd85f7b6af98bdac81b7d1685da87267fc47adea0735a42b95')
-depends=('ruby')
-source=("http://www.morningstarsecurity.com/downloads/urlcrazy-${pkgver}.tar.gz")
-md5sums=('bfe2e0c71cc5160530b773f15d242964')
package() {
install -d "${pkgdir}/usr/bin"