summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD19
2 files changed, 11 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8a22e2213d7e..a0da89250238 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,12 @@
pkgbase = urlview
pkgdesc = A curses URL parser for text files
pkgver = 0.9
- pkgrel = 9
+ pkgrel = 10
url = http://packages.qa.debian.org/u/urlview.html
arch = i686
arch = x86_64
license = GPL
- makedepends = patch
- makedepends = automake-1.11
- makedepends = autoconf
depends = bash
- depends = ncurses
source = http://ftp.debian.org/debian/pool/main/u/urlview/urlview_0.9.orig.tar.gz
source = http://ftp.debian.org/debian/pool/main/u/urlview/urlview_0.9-19.diff.gz
sha256sums = 746ff540ccf601645f500ee7743f443caf987d6380e61e5249fc15f7a455ed42
diff --git a/PKGBUILD b/PKGBUILD
index c411e4dd5a18..9cafde874394 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,23 +2,24 @@
pkgname=urlview
pkgver=0.9
-pkgrel=9
+pkgrel=10
_patchlevel=19
pkgdesc="A curses URL parser for text files"
arch=('i686' 'x86_64')
url="http://packages.qa.debian.org/u/urlview.html"
license=('GPL')
-depends=('bash' 'ncurses')
-makedepends=('patch' 'automake-1.11' 'autoconf')
-source=(http://ftp.debian.org/debian/pool/main/u/urlview/${pkgname}_$pkgver.orig.tar.gz
+depends=('bash')
+source=(http://ftp.debian.org/debian/pool/main/u/urlview/${pkgname}_$pkgver.orig.tar.gz \
http://ftp.debian.org/debian/pool/main/u/urlview/${pkgname}_$pkgver-$_patchlevel.diff.gz)
sha256sums=('746ff540ccf601645f500ee7743f443caf987d6380e61e5249fc15f7a455ed42'
'056883c17756f849fb9235596d274fbc5bc0d944fcc072bdbb13d1e828301585')
prepare() {
cd "${srcdir}"/$pkgname-$pkgver.orig
+
patch -Np1 -i "${srcdir}"/${pkgname}_${pkgver}-$_patchlevel.diff
- aclocal-1.11
+ aclocal
+ automake --foreign --ignore-deps --add-missing
}
build() {
@@ -30,12 +31,12 @@ build() {
package() {
cd "${srcdir}"/$pkgname-$pkgver.orig
-
+
install -d "${pkgdir}"/etc/urlview "${pkgdir}"/usr/share/man/man1
make prefix="${pkgdir}"/usr mandir="${pkgdir}"/usr/share/man install
-
- install -D -m755 url_handler.sh "${pkgdir}"/etc/urlview/url_handler.sh
- install -D -m644 sample.urlview "${pkgdir}"/etc/urlview/system.urlview
+
+ install -Dm755 url_handler.sh "${pkgdir}"/etc/urlview/url_handler.sh
+ install -Dm644 sample.urlview "${pkgdir}"/etc/urlview/system.urlview
install -d "${pkgdir}"/usr/bin
ln -fs /etc/urlview/url_handler.sh "${pkgdir}"/usr/bin/url_handler.sh
}