summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD30
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7627170a74e1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = urutau-icons-git
+ pkgdesc = The most complete package of icons for third-party applications with elementary OS design
+ pkgver = latest
+ pkgrel = 1
+ url = https://github.com/btd1337/urutau-icons
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ conflicts = urutau-icons
+ options = !strip
+ source = git+https://github.com/btd1337/urutau-icons.git
+ sha256sums = SKIP
+
+pkgname = urutau-icons-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b0dc116bd030
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Helder Bertoldo <helder.bertoldo@gmail.com>
+
+pkgname=urutau-icons-git
+_gitname=urutau-icons
+pkgver=latest
+pkgrel=1
+pkgdesc="The most complete package of icons for third-party applications with elementary OS design"
+arch=('i686' 'x86_64')
+url="https://github.com/btd1337/${_gitname}"
+license=('GPL3')
+makedepends=('git')
+options=('!strip')
+conflicts=(${_gitname})
+source=("git+${url}.git")
+sha256sums=('SKIP')
+
+pkgver(){
+ cd ${_gitname}
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ install -d ${pkgdir}/usr/share/icons
+ cp -r ${srcdir}/${_gitname}* ${pkgdir}/usr/share/icons/
+ find ${pkgdir}/usr -type f -exec chmod 644 {} \;
+ find ${pkgdir}/usr -type d -exec chmod 755 {} \;
+ find ${pkgdir}/usr -type f -name '.directory' -delete
+ gsettings set org.gnome.desktop.interface icon-theme "${_gitname}"
+}
+