summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD33
-rw-r--r--urxvt-tabbedex-git.install12
3 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2362efb3d010
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+# Generated by makepkg 4.2.1
+# Mon Jun 1 13:54:34 UTC 2015
+pkgbase = urxvt-tabbedex-git
+ pkgdesc = Tabbed plugin for rxvt-unicode with many enhancements, development version
+ pkgver = 20120216
+ pkgrel = 1
+ url = http://github.com/stepb/urxvt-tabbedex
+ install = urxvt-tabbedex-git.install
+ arch = any
+ license = GPL
+ makedepends = git
+ depends = rxvt-unicode
+ provides = urxvt-tabbedex
+ conflicts = urxvt-tabbedex
+
+pkgname = urxvt-tabbedex-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..21209c2d5f37
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Johannes Löthberg <demizide@gmail.com>
+# Contributor: M Rawash <mrawash@gmail.com>
+
+pkgname="urxvt-tabbedex-git"
+pkgver=20120216
+pkgrel=1
+pkgdesc="Tabbed plugin for rxvt-unicode with many enhancements, development version"
+arch=("any")
+url='http://github.com/stepb/urxvt-tabbedex'
+license=("GPL")
+depends=('rxvt-unicode')
+makedepends=('git')
+provides=('urxvt-tabbedex')
+conflicts=('urxvt-tabbedex')
+install=${pkgname}.install
+
+_gitroot="git://github.com/stepb/urxvt-tabbedex.git"
+_gitname="urxvt-tabbedex"
+
+build() {
+ msg "Connecting to ${_gitroot}..."
+
+ if [ -d ${srcdir}/${_gitname} ] ; then
+ cd ${srcdir}/${_gitname} && git pull origin master
+ else
+ git clone $_gitroot
+ fi
+
+ msg "GIT checkout done or server timeout"
+ msg "Starting Installation..."
+
+ install -Dm644 ${srcdir}/${_gitname}/tabbedex ${pkgdir}/usr/lib/urxvt/perl/tabbedex
+}
diff --git a/urxvt-tabbedex-git.install b/urxvt-tabbedex-git.install
new file mode 100644
index 000000000000..c726bc405e6a
--- /dev/null
+++ b/urxvt-tabbedex-git.install
@@ -0,0 +1,12 @@
+post_install () {
+ echo "==> To enable tabbedex place the following in ~/.Xdefaults"
+ echo "==> URxvt.perl-ext-common: default,tabbedex"
+ echo "==> For documentation see urxvtperl man file (section on the tabbed"
+ echo "==> extension), also see the comments at the top of the tabbedex source"
+ echo "==> code: /usr/lib/urxvt/perl/tabbedex"
+}
+
+post_upgrade () {
+ post_install $1
+}
+