summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD6
2 files changed, 6 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 46235e93a64e..22f915cc7c9b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = ustreamer
pkgdesc = Lightweight and fast MJPG-HTTP streamer
- pkgver = 0.79
+ pkgver = 0.80
pkgrel = 1
url = https://github.com/pi-kvm/ustreamer
arch = i686
@@ -13,7 +13,7 @@ pkgbase = ustreamer
depends = libjpeg
depends = libevent
depends = libutil-linux
- source = ustreamer::git+https://github.com/pi-kvm/ustreamer#commit=v0.79
+ source = ustreamer::git+https://github.com/pi-kvm/ustreamer#commit=v0.80
md5sums = SKIP
pkgname = ustreamer
diff --git a/PKGBUILD b/PKGBUILD
index 37e92d817c5e..1a716bbd0a43 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=ustreamer
-pkgver=0.79
+pkgver=0.80
pkgrel=1
pkgdesc="Lightweight and fast MJPG-HTTP streamer"
url="https://github.com/pi-kvm/ustreamer"
@@ -11,6 +11,7 @@ license=(GPL)
arch=(i686 x86_64 armv6h armv7h)
depends=(libjpeg libevent libutil-linux)
# optional: raspberrypi-firmware for OMX JPEG encoder
+# optional: wiringpi for GPIO support
makedepends=(gcc make)
source=(${pkgname}::"git+https://github.com/pi-kvm/ustreamer#commit=v${pkgver}")
md5sums=(SKIP)
@@ -23,7 +24,8 @@ build() {
cd $pkgname-build
local _options=""
- [ -d /opt/vc/include ] && _options="$_options WITH_OMX_ENCODER=1"
+ [ -e /opt/vc/include/IL/OMX_Core.h ] && _options="$_options WITH_OMX=1"
+ [ -e /usr/include/wiringPi.h ] && _options="$_options WITH_GPIO=1"
make $_options CFLAGS="$CFLAGS" LDFLAGS="$LDFLAGS" $MAKEFLAGS
}