summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD22
2 files changed, 11 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 784cd7258c63..5a667106939f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = uswsusp-git
pkgdesc = Userspace software suspend - git checkout
- pkgver = 0.r501.g668c5f7
- pkgrel = 7
+ pkgver = 1.0
+ pkgrel = 9
url = http://suspend.sourceforge.net/
install = uswsusp.install
arch = i686
@@ -9,7 +9,7 @@ pkgbase = uswsusp-git
license = GPL
makedepends = git
depends = libx86
- depends = lzo2
+ depends = lzo
depends = pciutils
provides = uswsusp
conflicts = uswsusp
diff --git a/PKGBUILD b/PKGBUILD
index 5cc7164f7f66..52989e63224e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,15 @@
-# Maintainer: Christian Hesse <mail@eworm.de>
+# Maintainer: Felix Uhl <aur@mail.felix-uhl.de>
+# Contributor: Christian Hesse <mail@eworm.de>
# Contributor: cantabile <cantabile dot desu at gmail dot com>
pkgname=uswsusp-git
-pkgver=0.r501.g668c5f7
-pkgrel=7
+pkgver=1.0
+pkgrel=9
pkgdesc='Userspace software suspend - git checkout'
arch=('i686' 'x86_64')
url='http://suspend.sourceforge.net/'
license=('GPL')
-depends=('libx86' 'lzo2' 'pciutils')
+depends=('libx86' 'lzo' 'pciutils')
makedepends=('git')
provides=('uswsusp')
conflicts=('uswsusp')
@@ -29,16 +30,6 @@ sha256sums=('SKIP'
'd8a4f646d0785adf038830f14564f20ea307a27f225c17eb581a2e4d5e0c8519'
'fc303c78d3ae0794f8a267e9b8b9fec665b7413f396310d1a19efedcd2a1760d')
-pkgver() {
- cd suspend-utils/
-
- if GITTAG="$(git describe --abbrev=0 --tags 2>/dev/null)"; then
- echo "$(sed -e "s/^${pkgname%%-git}//" -e 's/^[-_/a-zA-Z]\+//' -e 's/[-_+]/./g' <<< ${GITTAG}).r$(git rev-list --count ${GITTAG}..).g$(git log -1 --format="%h")"
- else
- echo "0.r$(git rev-list --count master).g$(git log -1 --format="%h")"
- fi
-}
-
build() {
cd suspend-utils/
@@ -57,6 +48,9 @@ build() {
# For the time being encrypt support is disabled. To reenable add
# --enable-encrypt below and fix the code.
+ # This is necessary for gcc >= 10
+ CFLAGS="$CFLAGS -fcommon"
+
./configure \
--prefix=/usr \
--sbindir=/usr/bin \