summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO38
-rw-r--r--PKGBUILD93
-rw-r--r--ut2004.desktop8
-rw-r--r--ut2004.install3
-rw-r--r--ut2004.pngbin0 -> 93315 bytes
-rw-r--r--ut2004.sh10
6 files changed, 123 insertions, 29 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4da97ac69a35..0bbc64d0cc86 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,29 @@
pkgbase = ut2004-gog
- pkgdesc = Popular first person shooter, native Linux version. (GOG version)
- pkgver = 1
- pkgrel = 1
- url = https://github.com/tim241/ut2004-gog
+ pkgdesc = Unreal Tournament 2004 ECE native Linux version with data via GOG
+ pkgver = 3369
+ pkgrel = 5
+ url = https://www.gog.com/game/unreal_tournament_2004_ece
+ arch = i686
arch = x86_64
- depends = bash
- depends = awk
- depends = sed
- depends = curl
- depends = wine
- depends = winetricks
+ license = custom
+ makedepends = lgogdownloader
+ makedepends = innoextract
+ depends = sdl
+ depends = openal
depends = libstdc++5
- depends = coreutils
- source = git+https://github.com/tim241/ut2004-gog.git
- sha256sums = SKIP
+ conflicts = ut2004
+ conflicts = ut2004-steam
+ source = setup_unreal_tournament_2004_1.0_(18947).exe::gogdownloader://unreal_tournament_2004_ece/en1installer0
+ source = setup_unreal_tournament_2004_1.0_(18947)-1.bin::gogdownloader://unreal_tournament_2004_ece/en1installer1
+ source = https://github.com/jm2/archlinux-package-ut2004-steam/raw/master/ut2004-lnxpatch3369-2.tar.bz2
+ source = ut2004.desktop
+ source = ut2004.png
+ source = ut2004.sh
+ sha256sums = 1f8712b4da90a22d822e4f2c2a4d841df2692be96d0f85f9064c6c77480c3b85
+ sha256sums = 81b6c1cf3931bf030d918461a134eff49921a0809cf215a6066639d0e6f0bf67
+ sha256sums = 438b9b13a367d46f23cce12b065382a55afa2fc68add1f1dd3db03b015f60bb3
+ sha256sums = daf88b168e941d0bdd6c6637934a98d703f962afec7c64a1502c5b82ff66c6c8
+ sha256sums = 9fd35b406dc32caa6a0700bda89ac72f561346b919c4764d943bf4198ec032fd
+ sha256sums = bd03cfb6a2006cb8a7786111e156b4a71f31ea1af38fc1329c8364d6082bb952
pkgname = ut2004-gog
-
diff --git a/PKGBUILD b/PKGBUILD
index acec00654ae7..369b745910c9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,85 @@
+# Maintainer: John-Michael Mulesa <jmulesa [at] gmail [dot] com>
+# Contributor: Alan Jenkins <alan.james.jenkins [at] gmail [dot] com>
+# Contributor: NiteHogg <keith.b.elliott [at] gmail [dot] com>
+# Contributor: Slash <demodevil5 [at] yahoo [dot] com>
+# Contributor: Karsten Anderson <orbitcoder@gmail.com>
+
pkgname=ut2004-gog
-pkgver=1
-pkgrel=1
-pkgdesc="Popular first person shooter, native Linux version. (GOG version)"
-arch=('x86_64')
-url="https://github.com/tim241/ut2004-gog"
+pkgver=3369
+_pkgvermaj=3369
+_pkgvermin=2
+pkgrel=5
+pkgdesc="Unreal Tournament 2004 ECE native Linux version with data via GOG"
+arch=('i686' 'x86_64')
+url="https://www.gog.com/game/unreal_tournament_2004_ece"
+license=('custom')
+depends=('sdl' 'openal' 'libstdc++5')
+makedepends=('lgogdownloader' 'innoextract')
+conflicts=('ut2004' 'ut2004-steam')
+source=("setup_unreal_tournament_2004_1.0_(18947).exe::gogdownloader://unreal_tournament_2004_ece/en1installer0"
+ "setup_unreal_tournament_2004_1.0_(18947)-1.bin::gogdownloader://unreal_tournament_2004_ece/en1installer1"
+ "https://github.com/jm2/archlinux-package-ut2004-steam/raw/master/ut2004-lnxpatch$_pkgvermaj-$_pkgvermin.tar.bz2"
+ "ut2004.desktop"
+ "ut2004.png"
+ "ut2004.sh")
+sha256sums=('1f8712b4da90a22d822e4f2c2a4d841df2692be96d0f85f9064c6c77480c3b85'
+ '81b6c1cf3931bf030d918461a134eff49921a0809cf215a6066639d0e6f0bf67'
+ '438b9b13a367d46f23cce12b065382a55afa2fc68add1f1dd3db03b015f60bb3'
+ 'daf88b168e941d0bdd6c6637934a98d703f962afec7c64a1502c5b82ff66c6c8'
+ '9fd35b406dc32caa6a0700bda89ac72f561346b919c4764d943bf4198ec032fd'
+ 'bd03cfb6a2006cb8a7786111e156b4a71f31ea1af38fc1329c8364d6082bb952')
-depends=('bash' 'awk' 'sed' 'curl' 'wine' 'winetricks' 'libstdc++5' 'coreutils')
+# If you want to use lgogdownloader add the following to /etc/makepkg.conf
+# DLAGENTS+=('gogdownloader::/usr/bin/lgogdownloader --download-file=%u -o %o')
+DLAGENTS+=("gogdownloader::/usr/bin/echo Could not find gog installer file (%u). Manually download it to \"$(pwd)\", or set up a gogdownloader:// DLAGENT in /etc/makepkg.conf. See PKGBUILD for example.")
-source=("git+https://github.com/tim241/${pkgname}.git")
+package() {
+ # Making sure directories exist.
+ install -d $pkgdir/usr/share/{applications,pixmaps,licenses}
+ install -d $pkgdir/opt/ut2004
+ install -d $pkgdir/opt/ut2004/{Animations,Help,Textures,Web,Benchmark,ForceFeedback,KarmaData,Maps,Music,StaticMeshes,Sounds,Speech,System}
+ install -d $pkgdir/usr/bin/
-sha256sums=('SKIP')
+ # Install the GOG UT2004 data.
+ innoextract "$srcdir/setup_unreal_tournament_2004_1.0_(18947).exe" -d "$pkgdir/opt/ut2004/"
-pkgver() {
- git describe --always
-}
+ # Install UT2004 Linux patch data.
+ cp -R $srcdir/UT2004-Patch/* $pkgdir/opt/ut2004
-package() {
- cd "$pkgname"
- install -D ut2004-gog "$pkgdir"/usr/bin/ut2004-gog
- install -D ut2004-linux.tar.gz "$pkgdir"/opt/ut2004-gog/ut2004-linux.tar.gz
+ # Install helper scripts.
+ install -D -m 755 $srcdir/ut2004.sh \
+ $pkgdir/opt/ut2004/Scripts/ut2004
+
+ # Install license.
+ install -D -m 644 $srcdir/UT2004-Patch/System/License.int \
+ $pkgdir/usr/share/licenses/$pkgname/LICENSE
+
+ # Install desktop file.
+ install -D -m 644 $srcdir/ut2004.desktop \
+ $pkgdir/usr/share/applications/ut2004.desktop
+
+ # Install icon file.
+ install -D -m 644 $srcdir/ut2004.png \
+ $pkgdir/usr/share/pixmaps/ut2004.png
+
+ # Create symlinks to add the ut2004 startup and utility scripts to usr/bin
+ ln -s /opt/ut2004/Scripts/ut2004 $pkgdir/usr/bin/ut2004 || return 1
+
+ if [ "$CARCH" == "x86_64" ]
+ then
+ sed 's/ut2004-bin/&-linux-amd64/g' $pkgdir/opt/ut2004/Scripts/ut2004 > $pkgdir/opt/ut2004/Scripts/ut2004.TMP
+
+ install -D -m 755 $pkgdir/opt/ut2004/Scripts/ut2004.TMP $pkgdir/opt/ut2004/Scripts/ut2004
+ else
+ rm $pkgdir/opt/ut2004/System/ucc-bin-linux-amd64
+ rm $pkgdir/opt/ut2004/System/ut2004-bin-linux-amd64
+ fi
+
+ # Create symbolic links to system libraries in game directory.
+ ln -s /usr/lib/libSDL-1.2.so.0 $pkgdir/opt/ut2004/System || return 1
+ chmod 644 $pkgdir/opt/ut2004/System/libSDL-1.2.so.0 || return 1
+ ln -s /usr/lib/libopenal.so $pkgdir/opt/ut2004/System/openal.so || return 1
+ chmod 644 $pkgdir/opt/ut2004/System/openal.so || return 1
}
+
+# vim:set ts=2 sw=2 et:
diff --git a/ut2004.desktop b/ut2004.desktop
new file mode 100644
index 000000000000..317f5f18e52f
--- /dev/null
+++ b/ut2004.desktop
@@ -0,0 +1,8 @@
+[Desktop Entry]
+Name=UT2004
+Comment=Unreal Tournament 2004
+Exec=/opt/ut2004/Scripts/ut2004
+Icon=ut2004
+Terminal=false
+Type=Application
+Categories=Application;Game;
diff --git a/ut2004.install b/ut2004.install
new file mode 100644
index 000000000000..51115cbbae71
--- /dev/null
+++ b/ut2004.install
@@ -0,0 +1,3 @@
+post_install() {
+ echo "To complete installation, write your UT2004 cdkey to /opt/ut2004/System/CDkey as root."
+}
diff --git a/ut2004.png b/ut2004.png
new file mode 100644
index 000000000000..c9cc0e132ab1
--- /dev/null
+++ b/ut2004.png
Binary files differ
diff --git a/ut2004.sh b/ut2004.sh
new file mode 100644
index 000000000000..16aac08f1c45
--- /dev/null
+++ b/ut2004.sh
@@ -0,0 +1,10 @@
+#! /bin/bash
+
+if [ ! -d "$HOME"/.ut2004 ] ; then
+ mkdir -p "$HOME"/.ut2004/System
+ cp /opt/ut2004/__support/app/System/* "$HOME"/.ut2004/System/
+ grep -FB1 CDKey /opt/ut2004/goggame-1207658691.script | grep -Po '"valueData": "\K[A-Z0-9-]*(?=",)' > "$HOME"/.ut2004/System/CDkey
+ chmod 600 "$HOME"/.ut2004/System/CDkey
+fi
+cd /opt/ut2004/System
+./ut2004-bin