summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD20
-rw-r--r--utimer.hlp28
3 files changed, 46 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 845c4587c2d5..2e01018006a6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,15 @@
pkgbase = utimer
- pkgdesc = A command-line multifunction timer tool.
+ pkgdesc = A command-line multifunction timer tool
pkgver = 0.4
- pkgrel = 8
- url = http://utimer.codealpha.net/utimer/
+ pkgrel = 9
+ url = https://sourceforge.net/projects/utimer/
arch = x86_64
arch = i686
license = GPL3
makedepends = intltool
depends = glib2
- source = http://utimer.codealpha.net/files/utimer-0.4.tar.gz
- sha1sums = b9590ef4ff6bb8ecf64bb703f50f1bfeddf3fbdd
+ source = https://launchpad.net/utimer/0.4/0.4/+download/utimer-0.4.tar.gz
+ sha256sums = 07a9d28e15155a10b7e6b22af05c84c878d95be782b6b0afaadec2f7884aa0f7
pkgname = utimer
diff --git a/PKGBUILD b/PKGBUILD
index aecfc8b4b490..50697c21d598 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,24 @@
-# Maintainer: Tobias Frilling <tobias@frilling-online.de>
+# Maintainer: David Birks <david@tellus.space>
+# Contributor: Tobias Frilling <tobias@frilling-online.de>
# Contributor: Joseph Kern <timetrap AT gmail DOT com>
+# package modding by g99
+
+
+# ./utimer -t 3 # will show a 3 seconds countdown. for whoever needing such stuff
+
+
pkgname=utimer
pkgver=0.4
-pkgrel=8
-pkgdesc="A command-line multifunction timer tool."
-url="http://utimer.codealpha.net/utimer/"
+pkgrel=9
+pkgdesc="A command-line multifunction timer tool"
+url="https://sourceforge.net/projects/utimer/"
license=('GPL3')
makedepends=('intltool')
depends=('glib2')
arch=('x86_64' 'i686')
-source=( http://utimer.codealpha.net/files/utimer-$pkgver.tar.gz )
-sha1sums=('b9590ef4ff6bb8ecf64bb703f50f1bfeddf3fbdd')
-
+source=("https://launchpad.net/utimer/0.4/0.4/+download/utimer-$pkgver.tar.gz")
+sha256sums=('07a9d28e15155a10b7e6b22af05c84c878d95be782b6b0afaadec2f7884aa0f7')
build() {
cd "$srcdir/$pkgname-$pkgver"
diff --git a/utimer.hlp b/utimer.hlp
new file mode 100644
index 000000000000..a7c5b1727d20
--- /dev/null
+++ b/utimer.hlp
@@ -0,0 +1,28 @@
+Usage:
+ utimer [OPTION…] [ARGUMENTS] - command-line "timer" which features a timer, a countdown and a stopwatch
+
+ µTimer (or "utimer", pronounced as "micro-timer") is a multifunction timer (command-line only).
+
+ The main features are:
+ - a timer (e.g. count from 0 to 4 minutes),
+ - a countdown (e.g. count from 10 minutes down to 0),
+ - a stopwatch.
+
+ µTimer always exits after the timer or countdown are done counting. This can be useful for using countdowns in scripts, for example. The stopwatch, which is not concerned, needs to be stopped manually using 'q'.
+
+Help Options:
+ -h, --help Show help options
+
+Application Options:
+ -t, --timer=TIMELENGTH count from 0 to TIMELENGTH and then exit (e.g. utimer -t 31m27s300ms)
+ -c, --countdown=TIMELENGTH count from TIMELENGTH down to 0 and exit (e.g. utimer -c 30d9h50s)
+ -s, --stopwatch start the stopwatch. Use 'Q' key to quit
+ -v, --verbose Verbose output
+ -q, --quiet Quiet output
+ --quit-with-success When hitting 'q' to end the program, exit with a SUCCESS exit status (0)
+ -L, --limits Show the limits of µTimer (Maximum time length, Accuracy...)
+ --version Display the current version of µTimer
+ -d, --debug Debug output
+
+
+Report any bug to: https://bugs.launchpad.net/utimer (bugs@utimer.codealpha.net)