aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD12
2 files changed, 9 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 360c3acdbc3f..28f4637ad8a2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
# Generated by mksrcinfo v8
-# Fri Feb 10 11:43:23 UTC 2017
-pkgbase = utopia-documents3
+# Fri Feb 10 11:46:28 UTC 2017
+pkgbase = utopia-documents
pkgdesc = PDF reader that displays interactive annotations on scientific articles
pkgver = 3.0.0
pkgrel = 1
@@ -26,5 +26,5 @@ pkgbase = utopia-documents3
sha256sums = 1c259b68fada7f98080a66a63e36c707b78bfc3a5c80a956568ee73c030c8cac
sha256sums = 808a26f259768507e864d729191b8dd85a6472f43d9c1f507dd775dd1eaedcc2
-pkgname = utopia-documents
+pkgname = utopia-documents3
diff --git a/PKGBUILD b/PKGBUILD
index ed0d6bae8347..2e61f8ee756d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
# Contributor: Zhu Jinxuan <zhujinxuan@gmail.com>
# Contributor: tdy tdy@archlinux.info
-pkgname=utopia-documents
-pkgbase=utopia-documents3
+pkgname=utopia-documents3
+pkgbase=utopia-documents
pkgver=3.0.0
pkgrel=1
pkgdesc="PDF reader that displays interactive annotations on scientific articles"
@@ -14,14 +14,14 @@ provides=('utopia-documents3')
conflicts=('utopia-documents')
depends=(libqglviewer pcre qt5-svg qt5-webkit qt5-script poppler-qt5 python2-pyqt5)
makedepends=(cmake boost swig glew)
-source=("http://utopiadocs.com/files/${pkgname}-${pkgver}.tgz" "configure.patch")
+source=("http://utopiadocs.com/files/${pkgbase}-${pkgver}.tgz" "configure.patch")
sha256sums=('1c259b68fada7f98080a66a63e36c707b78bfc3a5c80a956568ee73c030c8cac'
'808a26f259768507e864d729191b8dd85a6472f43d9c1f507dd775dd1eaedcc2')
prepare() {
PATCH="configure.patch"
-cd $pkgname-$pkgver
+cd $pkgbase-$pkgver
patch configure ../$PATCH
./configure --release
@@ -35,11 +35,11 @@ cp CMakeCache.txt.1 CMakeCache.txt
}
build() {
- cd $pkgname-$pkgver/build/Linux-Release
+ cd $pkgbase-$pkgver/build/Linux-Release
make -j4
}
package() {
- cd $pkgname-$pkgver/build/Linux-Release
+ cd $pkgbase-$pkgver/build/Linux-Release
make install
}