summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD22
-rw-r--r--utox-git.install17
3 files changed, 22 insertions, 25 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c90ee2272a8c..f11be5102562 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = utox-git
pkgdesc = Lightweight Tox client
- pkgver = 0.3.2.r41.gd16f539
- pkgrel = 2
- url = https://github.com/notsecure/uTox
+ pkgver = 0.3.2.r155.g42a8193
+ pkgrel = 1
+ url = https://github.com/GrayHatter/uTox
install = utox-git.install
arch = i686
arch = x86_64
@@ -24,7 +24,7 @@ pkgbase = utox-git
optdepends = gtk2: GTK file picker
provides = utox
conflicts = utox
- source = utox-git::git+https://github.com/notsecure/uTox
+ source = utox-git::git+https://github.com/GrayHatter/uTox
md5sums = SKIP
pkgname = utox-git
diff --git a/PKGBUILD b/PKGBUILD
index a23e26fc2655..a90cfd31e5c9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,11 +4,11 @@
_pkgname=utox
pkgname=utox-git
-pkgver=0.3.2.r41.gd16f539
-pkgrel=2
+pkgver=0.3.2.r155.g42a8193
+pkgrel=1
pkgdesc='Lightweight Tox client'
arch=('i686' 'x86_64' 'arm' 'armv6h' 'armv7h')
-url='https://github.com/notsecure/uTox'
+url='https://github.com/GrayHatter/uTox'
license=('GPL3')
depends=('desktop-file-utils'
'fontconfig'
@@ -22,23 +22,23 @@ depends=('desktop-file-utils'
'v4l-utils')
makedepends=('git')
optdepends=('gtk2: GTK file picker')
-provides=("${_pkgname}")
-conflicts=("${_pkgname}")
-source=("${pkgname}::git+https://github.com/notsecure/uTox")
+provides=("$_pkgname")
+conflicts=("$_pkgname")
+source=("$pkgname::git+https://github.com/GrayHatter/uTox")
md5sums=('SKIP')
-install="${pkgname}.install"
+install="$pkgname.install"
pkgver() {
- cd "${srcdir}/${pkgname}"
+ cd "$pkgname"
git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
- cd "${srcdir}/${pkgname}"
+ cd "$pkgname"
make
}
package() {
- cd "${srcdir}/${pkgname}"
- make PREFIX=/usr DESTDIR="${pkgdir}" install
+ cd "$pkgname"
+ make PREFIX=/usr DESTDIR="$pkgdir" install
}
diff --git a/utox-git.install b/utox-git.install
index 4361e58e9393..f6b9b8021fe7 100644
--- a/utox-git.install
+++ b/utox-git.install
@@ -1,15 +1,12 @@
-post_install()
-{
- xdg-icon-resource forceupdate --theme hicolor &>/dev/null
- update-desktop-database -q
+post_install() {
+ xdg-icon-resource forceupdate --theme hicolor &>/dev/null
+ update-desktop-database -q
}
-post_upgrade()
-{
- post_install $1
+post_upgrade() {
+ post_install $1
}
-post_remove()
-{
- post_install $1
+post_remove() {
+ post_install $1
}