summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD10
-rw-r--r--uwsgi_trick_chroot.patch2
3 files changed, 12 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a3b51190cd09..742f250e4174 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,8 @@
+# Generated by mksrcinfo v8
+# Sun Jul 15 05:02:25 UTC 2018
pkgbase = uwsgi-plugin-php53
pkgdesc = Plugin for PHP 5.3 support
- pkgver = 2.0.11.1
+ pkgver = 2.0.17.1
pkgrel = 1
url = http://projects.unbit.it/uwsgi
arch = i686
@@ -11,14 +13,14 @@ pkgbase = uwsgi-plugin-php53
depends = libyaml
depends = jansson
depends = uwsgi
- source = http://projects.unbit.it/downloads/uwsgi-2.0.11.1.tar.gz
+ source = http://projects.unbit.it/downloads/uwsgi-2.0.17.1.tar.gz
source = archlinux.ini
source = uwsgi_fix_rpath.patch
source = uwsgi_trick_chroot.patch
- md5sums = 087ba7b53bd4afc0f0218f5eb3398809
+ md5sums = 0b1d89f62d0a291ba837c57b2f5dae39
md5sums = 9aced0faffc5fc04afccf946e8a2a886
md5sums = 1a4516d5cdcf5b95b036f4eae2d0c152
- md5sums = 0c09a52fdb88f08c36a8b380f451ce6d
+ md5sums = a49705b98c28dee890b2f88cbaa58be3
pkgname = uwsgi-plugin-php53
diff --git a/PKGBUILD b/PKGBUILD
index a95c38daa3ff..9d7c51de4c63 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,7 +10,7 @@
pkgname=uwsgi-plugin-php53
pkgdesc="Plugin for PHP 5.3 support"
-pkgver=2.0.11.1
+pkgver=2.0.17.1
pkgrel=1
arch=(i686 x86_64)
url="http://projects.unbit.it/uwsgi"
@@ -22,16 +22,16 @@ source=(http://projects.unbit.it/downloads/uwsgi-$pkgver.tar.gz
uwsgi_fix_rpath.patch
uwsgi_trick_chroot.patch)
-md5sums=('087ba7b53bd4afc0f0218f5eb3398809'
+md5sums=('0b1d89f62d0a291ba837c57b2f5dae39'
'9aced0faffc5fc04afccf946e8a2a886'
'1a4516d5cdcf5b95b036f4eae2d0c152'
- '0c09a52fdb88f08c36a8b380f451ce6d')
+ 'a49705b98c28dee890b2f88cbaa58be3')
prepare(){
cd $srcdir/uwsgi-$pkgver
cp $srcdir/archlinux.ini buildconf/archlinux.ini
#sed -i 's/LIBS .*-lphp5.*/LIBS = []/' plugins/php/uwsgiplugin.py
- for patch in uwsgi_fix_rpath.patch uwsgi_trick_chroot.patch; do
+ for patch in uwsgi_trick_chroot.patch; do
patch -Np1 -i $srcdir/$patch
done
}
@@ -39,7 +39,7 @@ prepare(){
build() {
pushd $srcdir/uwsgi-$pkgver
- python2 uwsgiconfig.py --plugin plugins/php archlinux php53
+ UWSGICONFIG_PHPPATH=/usr/bin/php-config53 python2 uwsgiconfig.py --plugin plugins/php archlinux php53
}
package(){
diff --git a/uwsgi_trick_chroot.patch b/uwsgi_trick_chroot.patch
index 3bfb1ac220ae..663bba76b82d 100644
--- a/uwsgi_trick_chroot.patch
+++ b/uwsgi_trick_chroot.patch
@@ -7,7 +7,7 @@ index e447123..4d55f2c 100644
pass
- if uc:
-- plugin_dest = uc.get('plugin_dir') + '/' + name + '_plugin'
+- plugin_dest = uc.get('plugin_build_dir', uc.get('plugin_dir')) + '/' + name + '_plugin'
- else:
- plugin_dest = name + '_plugin'
+ plugin_dest = name + '_plugin'