summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.INSTALL15
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD9
3 files changed, 7 insertions, 21 deletions
diff --git a/.INSTALL b/.INSTALL
index d72871ce70cb..143ecc522d65 100644
--- a/.INSTALL
+++ b/.INSTALL
@@ -2,8 +2,6 @@
post_install() {
systemctl daemon-reload
- systemctl enable v2raya
- systemctl start v2raya
ECHOLEN=$(echo -e|awk '{print length($0)}')
if [ ${ECHOLEN} = '0' ]
@@ -19,8 +17,7 @@ post_install() {
post_upgrade() {
systemctl daemon-reload
- systemctl restart v2raya
-
+
ECHOLEN=$(echo -e|awk '{print length($0)}')
if [ ${ECHOLEN} = '0' ]
then
@@ -32,13 +29,3 @@ post_upgrade() {
$ECHO "\033[36m* Completed! *\033[0m"
$ECHO "\033[36m******************************\033[0m"
}
-
-pre_remove() {
- systemctl disable v2raya
- systemctl stop v2raya
- systemctl stop v2ray
-}
-
-post_remove() {
- systemctl daemon-reload
-}
diff --git a/.SRCINFO b/.SRCINFO
index 68ad6c900e7a..64d67b514157 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = v2raya
pkgdesc = A web GUI client of Project V which supports VMess, VLESS, SS, SSR, Trojan and Pingtunnel protocols
- pkgver = 1.4.4
+ pkgver = 1.5.0
pkgrel = 1
url = https://github.com/v2rayA/v2rayA
install = .INSTALL
@@ -17,7 +17,7 @@ pkgbase = v2raya
depends = glibc
optdepends = v2ray>=4.37.0-1
optdepends = xray>=1.4.2-1
- source = v2raya-1.4.4.tar.gz::https://github.com/v2rayA/v2rayA/archive/v1.4.4.tar.gz
+ source = v2raya-1.5.0.tar.gz::https://github.com/v2rayA/v2rayA/archive/v1.5.0.tar.gz
sha512sums = SKIP
pkgname = v2raya
diff --git a/PKGBUILD b/PKGBUILD
index e7c76971a52c..3618d290d760 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: mzz2017 <m@mzz.pub>
pkgname=v2raya
-pkgver=1.4.4
+pkgver=1.5.0
pkgrel=1
install=.INSTALL
pkgdesc="A web GUI client of Project V which supports VMess, VLESS, SS, SSR, Trojan and Pingtunnel protocols"
@@ -19,21 +19,20 @@ build() {
yarn config set registry https://registry.npm.taobao.org
yarn config set sass_binary_site https://cdn.npm.taobao.org/dist/node-sass -g
yarn --check-files
- yarn build
+ OUTPUT_DIR="$srcdir/v2rayA-$pkgver/service/server/router/web" yarn build
cd "$srcdir/v2rayA-$pkgver/service"
export GO111MODULE=on
export GOPROXY=https://goproxy.io
- CGO_ENABLED=0 go build -ldflags '-X github.com/v2rayA/v2rayA/global.Version='$pkgver' -s -w -extldflags "-static"' -o v2raya
+ go build -ldflags '-X github.com/v2rayA/v2rayA/global.Version='$pkgver' -s -w' -o v2raya
}
package() {
cd "${srcdir}"/"v2rayA-${pkgver}"/
install -Dm 755 service/v2raya -t "${pkgdir}"/usr/bin/
- find web -type d -exec install -vd "${pkgdir}"/etc/v2raya/{} \;
- find web -type f -exec install -vm 644 {} "${pkgdir}"/etc/v2raya/{} \;
install -dm 750 "${pkgdir}"/etc/v2raya/
install -Dm 644 install/universal/v2raya.desktop -t "${pkgdir}"/usr/share/applications/
install -Dm 644 install/universal/v2raya.service -t "${pkgdir}"/usr/lib/systemd/system/
+ install -Dm 644 install/universal/v2raya@.service -t "${pkgdir}"/usr/lib/systemd/system/
install -Dm 644 gui/public/img/icons/android-chrome-512x512.png "${pkgdir}"/usr/share/icons/hicolor/512x512/apps/v2raya.png
}