summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PKGBUILD18
1 files changed, 17 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 07e3eb107ad7..39bf7305f72a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -19,7 +19,7 @@ prepare() {
build() {
cd "V2RayA-$pkgver/service"
- go build -ldflags='-X V2RayA/global.Version=$pkgver' -o v2raya
+ go build -ldflags="-X V2RayA/global.Version=$pkgver" -o v2raya
}
package() {
@@ -27,3 +27,19 @@ package() {
install -Dm644 "install/v2raya.service" "$pkgdir/usr/lib/systemd/system/v2raya.service"
install -Dm755 "service/v2raya" -t "$pkgdir/usr/bin/"
}
+
+post_install() {
+ bash install/after_install.sh
+}
+
+post_remove() {
+ bash install/after_remove.sh
+}
+
+post_upgrade() {
+ bash install/after_upgrade.sh
+}
+
+pre_remove() {
+ bash install/before_remove.sh
+} \ No newline at end of file