summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD12
2 files changed, 9 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 36d5a076fa4a..8217dc197ad1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = v2raya
- pkgdesc = A V2Ray Linux client with web GUI, compatible with SS and SSR and supporting transparent proxy
+ pkgdesc = A web GUI client of Project V which supports V2Ray, SS, SSR, Trojan and PingTunnel protocols
pkgver = 0.7.0
pkgrel = 1
- url = https://github.com/mzz2017/V2RayA
+ url = https://github.com/mzz2017/v2rayA
install = .INSTALL
arch = i686
arch = x86_64
@@ -13,7 +13,7 @@ pkgbase = v2raya
makedepends = go>=2:1.11.3-1
depends = glibc
depends = v2ray
- source = v2raya-0.7.0.tar.gz::https://github.com/mzz2017/V2RayA/archive/v0.7.0.tar.gz
+ source = v2raya-0.7.0.tar.gz::https://github.com/mzz2017/v2rayA/archive/v0.7.0.tar.gz
sha512sums = SKIP
pkgname = v2raya
diff --git a/PKGBUILD b/PKGBUILD
index 370e25bbb646..7b7528d9e692 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,24 +4,24 @@ pkgname=v2raya
pkgver=0.7.0
pkgrel=1
install=.INSTALL
-pkgdesc="A V2Ray Linux client with web GUI, compatible with SS and SSR and supporting transparent proxy"
+pkgdesc="A web GUI client of Project V which supports V2Ray, SS, SSR, Trojan and PingTunnel protocols"
arch=('i686' 'x86_64' 'armv7h' 'armv6h' 'aarch64')
-url="https://github.com/mzz2017/V2RayA"
+url="https://github.com/mzz2017/v2rayA"
license=('GPL')
depends=('glibc' 'v2ray')
makedepends=('go>=2:1.12.3-1')
-source=("$pkgname-$pkgver.tar.gz::https://github.com/mzz2017/V2RayA/archive/v$pkgver.tar.gz")
+source=("$pkgname-$pkgver.tar.gz::https://github.com/mzz2017/v2rayA/archive/v$pkgver.tar.gz")
sha512sums=('SKIP')
build() {
- cd "V2RayA-$pkgver/service"
+ cd "v2rayA-$pkgver/service"
export GO111MODULE=on
export GOPROXY=https://goproxy.io
- go build -ldflags="-X V2RayA/global.Version=$pkgver" -o v2raya
+ go build -ldflags="-X v2rayA/global.Version=$pkgver" -o v2raya
}
package() {
- cd "$srcdir/V2RayA-$pkgver"
+ cd "$srcdir/v2rayA-$pkgver"
install -Dm644 "install/universal/v2raya.service" "$pkgdir/usr/lib/systemd/system/v2raya.service"
install -Dm755 "service/v2raya" -t "$pkgdir/usr/bin/"