summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.INSTALL32
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD19
3 files changed, 37 insertions, 19 deletions
diff --git a/.INSTALL b/.INSTALL
new file mode 100644
index 000000000000..27fc45680e1a
--- /dev/null
+++ b/.INSTALL
@@ -0,0 +1,32 @@
+post_install() {
+ :
+#!/bin/sh
+
+systemctl daemon-reload
+systemctl enable v2raya
+systemctl start v2raya
+
+}
+post_upgrade() {
+ :
+#!/bin/sh
+
+systemctl restart v2raya
+
+}
+pre_remove() {
+ :
+#!/bin/sh
+
+systemctl disable v2raya
+ststemctl stop v2raya
+ststemctl stop v2ray
+
+}
+post_remove() {
+ :
+#!/bin/sh
+
+systemctl daemon-reload
+
+}
diff --git a/.SRCINFO b/.SRCINFO
index 7d430daeedf2..a6968a8c2857 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,9 @@
pkgbase = v2raya
pkgdesc = V2RayA是一个支持全局透明代理的V2Ray Linux客户端。
- pkgver = 0.3.4
+ pkgver = {{pkgver}}
pkgrel = 1
url = https://github.com/mzz2017/V2RayA
+ install = .INSTALL
arch = i686
arch = x86_64
arch = armv7h
@@ -12,7 +13,7 @@ pkgbase = v2raya
makedepends = go>=2:1.11.3-1
depends = glibc
depends = v2ray
- source = v2raya-0.3.4.tar.gz::https://github.com/mzz2017/V2RayA/archive/v0.3.4.tar.gz
+ source = v2raya-{{pkgver}}.tar.gz::https://github.com/mzz2017/V2RayA/archive/v{{pkgver}}.tar.gz
sha512sums = SKIP
pkgname = v2raya
diff --git a/PKGBUILD b/PKGBUILD
index 0012f16bcac1..0f93ef57645b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,9 @@
# Maintainer: mzz2017 <m@mzz.pub>
pkgname=v2raya
-pkgver=0.3.4
+pkgver={{pkgver}}
pkgrel=1
+install:.INSTALL
pkgdesc="V2RayA是一个支持全局透明代理的V2Ray Linux客户端。"
arch=('i686' 'x86_64' 'armv7h' 'armv6h' 'aarch64')
url="https://github.com/mzz2017/V2RayA"
@@ -27,19 +28,3 @@ package() {
install -Dm644 "install/v2raya.service" "$pkgdir/usr/lib/systemd/system/v2raya.service"
install -Dm755 "service/v2raya" -t "$pkgdir/usr/bin/"
}
-
-post_install() {
- bash install/after_install.sh
-}
-
-post_remove() {
- bash install/after_remove.sh
-}
-
-post_upgrade() {
- bash install/after_upgrade.sh
-}
-
-pre_remove() {
- bash install/before_remove.sh
-} \ No newline at end of file