summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD7
2 files changed, 5 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 491494b6ca54..6ad0c66b5f76 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = v2raya-git
pkgdesc = v2rayA nightly version
- pkgver = 20210820.r827.a2b542a
+ pkgver = 20210827.r870.ee7205f
pkgrel = 1
url = https://github.com/v2rayA/v2rayA
install = .INSTALL
diff --git a/PKGBUILD b/PKGBUILD
index 86afdc242efc..a34b72205195 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: mzz2017 <mzz@tuta.io>
pkgname=v2raya-git
-pkgver=20210824.r828.d0fe4c2
+pkgver=20210827.r870.ee7205f
pkgrel=1
install=.INSTALL
pkgdesc="v2rayA nightly version"
@@ -29,12 +29,13 @@ build() {
yarn config set registry https://registry.npm.taobao.org
yarn config set sass_binary_site https://cdn.npm.taobao.org/dist/node-sass -g
yarn --check-files
- OUTPUT_DIR="$srcdir/$pkgname/service/server/router/web" yarn build
+ export OUTPUT_DIR="$srcdir/$pkgname/service/server/router/web"
+ yarn build
cd "$srcdir/$pkgname/service"
export GO111MODULE=on
export GOPROXY=https://goproxy.io
- go build -ldflags '-X github.com/v2rayA/v2rayA/global.Version=unstable -s -w' -o v2raya
+ go build -ldflags '-X github.com/v2rayA/v2rayA/conf.Version=unstable-'"$(pkgver)"' -s -w' -o v2raya
}
package() {