summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD4
2 files changed, 5 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 322c38ae3f82..7361519ae1b7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -16,10 +16,11 @@ pkgbase = v2raya-git
makedepends = yarn
makedepends = python2
depends = glibc
- depends = v2ray>=5.0.0
provides = v2raya
conflicts = v2raya
source = v2raya-git::git+https://github.com/v2rayA/v2rayA#branch=feat_v5
sha512sums = SKIP
pkgname = v2raya-git
+ depends = glibc
+ depends = v2ray>=5.0.0
diff --git a/PKGBUILD b/PKGBUILD
index 69c980f1f3d9..a976e3308625 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,7 @@ pkgdesc="v2rayA nightly version"
arch=('i686' 'x86_64' 'armv7h' 'armv6h' 'aarch64')
url="https://github.com/v2rayA/v2rayA"
license=('GPL3')
-depends=('glibc' 'v2ray>=5.0.0')
+depends=('glibc')
makedepends=('git' 'go>=2:1.16.0-1' 'nodejs>=14' 'yarn' 'python2')
provides=('v2raya')
conflicts=('v2raya')
@@ -36,6 +36,8 @@ build() {
}
package() {
+ depends+=('v2ray>=5.0.0')
+
cd "${srcdir}"/"${pkgname}"/
install -Dm 755 service/v2raya -t "${pkgdir}"/usr/bin/
install -dm 750 "${pkgdir}"/etc/v2raya/