summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.INSTALL12
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD8
3 files changed, 5 insertions, 17 deletions
diff --git a/.INSTALL b/.INSTALL
index d72871ce70cb..9e7631610896 100644
--- a/.INSTALL
+++ b/.INSTALL
@@ -2,8 +2,6 @@
post_install() {
systemctl daemon-reload
- systemctl enable v2raya
- systemctl start v2raya
ECHOLEN=$(echo -e|awk '{print length($0)}')
if [ ${ECHOLEN} = '0' ]
@@ -19,7 +17,6 @@ post_install() {
post_upgrade() {
systemctl daemon-reload
- systemctl restart v2raya
ECHOLEN=$(echo -e|awk '{print length($0)}')
if [ ${ECHOLEN} = '0' ]
@@ -33,12 +30,3 @@ post_upgrade() {
$ECHO "\033[36m******************************\033[0m"
}
-pre_remove() {
- systemctl disable v2raya
- systemctl stop v2raya
- systemctl stop v2ray
-}
-
-post_remove() {
- systemctl daemon-reload
-}
diff --git a/.SRCINFO b/.SRCINFO
index ba6ac686fb7b..ae79fecac12a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = v2raya-git
pkgdesc = v2rayA nightly version
- pkgver = 20210805.r770.5f51899
+ pkgver = 20210820.r827.a2b542a
pkgrel = 1
url = https://github.com/v2rayA/v2rayA
install = .INSTALL
diff --git a/PKGBUILD b/PKGBUILD
index 7ba2c133c4ea..81241058dd5b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: mzz2017 <mzz@tuta.io>
pkgname=v2raya-git
-pkgver=20210807.r793.3414a0c
+pkgver=20210820.r827.a2b542a
pkgrel=1
install=.INSTALL
pkgdesc="v2rayA nightly version"
@@ -29,13 +29,12 @@ build() {
yarn config set registry https://registry.npm.taobao.org
yarn config set sass_binary_site https://cdn.npm.taobao.org/dist/node-sass -g
yarn --check-files
- yarn build
- mv "$srcdir/v2raya-git/web" "$srcdir/v2raya-git/service/server/router/"
+ OUTPUT_DIR="$srcdir/$pkgname/service/server/router/web" yarn build
cd "$srcdir/$pkgname/service"
export GO111MODULE=on
export GOPROXY=https://goproxy.io
- CGO_ENABLED=0 go build -ldflags '-X github.com/v2rayA/v2rayA/global.Version=unstable -s -w -extldflags "-static"' -o v2raya
+ go build -ldflags '-X github.com/v2rayA/v2rayA/global.Version=unstable -s -w' -o v2raya
}
package() {
@@ -44,5 +43,6 @@ package() {
install -dm 750 "${pkgdir}"/etc/v2raya/
install -Dm 644 install/universal/v2raya.desktop -t "${pkgdir}"/usr/share/applications/
install -Dm 644 install/universal/v2raya.service -t "${pkgdir}"/usr/lib/systemd/system/
+ install -Dm 644 install/universal/v2raya@.service -t "${pkgdir}"/usr/lib/systemd/system/
install -Dm 644 gui/public/img/icons/android-chrome-512x512.png "${pkgdir}"/usr/share/icons/hicolor/512x512/apps/v2raya.png
}