summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD4
2 files changed, 3 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 93f18793a943..9f53278eb54e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = v8-3.14
pkgdesc = A fast and modern javascript engine (old 3.14 version required R package V8)
pkgver = 3.14.5
- pkgrel = 6
+ pkgrel = 7
url = http://code.google.com/p/v8
arch = i686
arch = x86_64
@@ -53,4 +53,3 @@ pkgbase = v8-3.14
sha256sums = c67da79111fa171a0900af0da9b151a1568b233f4929922e72d049d7490f98df
pkgname = v8-3.14
-
diff --git a/PKGBUILD b/PKGBUILD
index 5396ffb79385..698581bb663a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
pkgname=v8-3.14
pkgver=3.14.5
-pkgrel=6
+pkgrel=7
pkgdesc='A fast and modern javascript engine (old 3.14 version required R package 'V8')'
arch=('i686' 'x86_64')
url='http://code.google.com/p/v8'
@@ -93,7 +93,7 @@ build() {
# keep old ABI to prevent symbol changes due to GCC5 transition
# https://wiki.debian.org/GCC5
- export CXXFLAGS="${CXXFLAGS} -fno-delete-null-pointer-checks -std=c++98 -Wno-class-memaccess -Wno-cast-function-type -Wno-error=stringop-truncation -Wno-error=array-bounds -Wno-error=stringop-overflow"
+ export CXXFLAGS="${CXXFLAGS} -fno-delete-null-pointer-checks -std=c++98 -Wno-class-memaccess -Wno-cast-function-type -Wno-error=stringop-truncation -Wno-error=array-bounds -Wno-error=stringop-overflow -Wno-error=misleading-indentation -Wno-error=nonnull -Wno-error=mismatched-new-delete"
export GYPFLAGS="-Dhost_arch=$ARCH -DOS=linux"