summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD30
2 files changed, 17 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 81066ff6592f..2f8cbb195a44 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Tue Nov 1 17:51:37 UTC 2016
+# Mon Nov 28 19:05:25 UTC 2016
pkgbase = valum
pkgdesc = Web micro-framework written in Vala
- pkgver = 0.2.6+482+ga066e6d
+ pkgver = 0.3.0
pkgrel = 1
url = https://github.com/valum-framework/valum
arch = i686
@@ -21,7 +21,7 @@ pkgbase = valum
optdepends = libmemcached: For memcached cache storage.
optdepends = memcached: For memcached cache storage.
optdepends = luajit: For an embedded Lua VM.
- source = git://github.com/antono/valum.git#commit=a066e6d40980aec02c9e1b5cadb931719541f0cc
+ source = git://github.com/antono/valum.git#commit=30c2b15f26cabbd62aa279deb88b652e43d05f0a
md5sums = SKIP
pkgname = valum
diff --git a/PKGBUILD b/PKGBUILD
index bf2ebcab7b27..b0bf6bd81b07 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Adria Arrufat <adria.arrufat+AUR@protonmail.ch>
# Contributor: Philipp Trommler <ph.trommler@gmail.com>
pkgname=valum
-pkgver=0.2.6+482+ga066e6d
+pkgver=0.3.0
pkgrel=1
pkgdesc="Web micro-framework written in Vala"
arch=("i686" "x86_64")
@@ -12,7 +12,7 @@ optdepends=("libmemcached: For memcached cache storage."
"memcached: For memcached cache storage."
"luajit: For an embedded Lua VM.")
makedepends=(git ninja vala meson)
-_commit=a066e6d40980aec02c9e1b5cadb931719541f0cc
+_commit=30c2b15f26cabbd62aa279deb88b652e43d05f0a
source=("git://github.com/antono/valum.git#commit=${_commit}")
md5sums=("SKIP")
@@ -25,7 +25,7 @@ build() {
cd ${pkgname}
[ -d build ] && rm -rf build
mkdir build && cd build
- meson ..
+ meson --prefix=${pkgdir}/usr ..
ninja
}
@@ -36,24 +36,22 @@ check() {
package() {
cd ${pkgname}/build
- DESTDIR=${pkgdir} ninja install
+ ninja install
# hack: place installation in /usr/ and not /usr/local
- cd ${pkgdir}
- for d in `ls usr/local`; do
- mv usr/local/$d usr/$d
- done
- mv usr/lib64 usr/lib
- rm -rf usr/local
- cd usr/lib/pkgconfig
- for f in `ls *pc`; do
- sed -i $f -e "s/\/local//g"
- done
+ # cd ${pkgdir}
+ # for d in `ls usr/local`; do
+ # mv usr/local/$d usr/$d
+ # done
+ # mv usr/lib64 usr/lib
+ # rm -rf usr/local
+ # cd usr/lib/pkgconfig
+ # for f in `ls *pc`; do
+ # sed -i $f -e "s/\/local//g"
+ # done
# end of hack
cd ${srcdir}/valum
- install -Dm644 examples/app/vapi/ctpl.vapi "${pkgdir}/usr/share/vala/vapi/"
- install -Dm644 src/vsgi/servers/fcgi.{deps,vapi} "${pkgdir}/usr/share/vala/vapi/"
install -Dm644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}