summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD13
2 files changed, 9 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7e79ab1e418a..656223b63b35 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,6 @@
-# Generated by mksrcinfo v8
-# Sat Mar 2 19:52:21 UTC 2019
pkgbase = vapoursynth-plugin-bifrost-git
pkgdesc = Plugin for Vapoursynth: bifrost (GIT version)
- pkgver = v2.2.2.g3082823
+ pkgver = 2.2.2.g3082823
pkgrel = 1
url = https://github.com/dubhater/vapoursynth-bifrost
arch = x86_64
@@ -11,8 +9,8 @@ pkgbase = vapoursynth-plugin-bifrost-git
depends = vapoursynth
provides = vapoursynth-plugin-bifrost
conflicts = vapoursynth-plugin-bifrost
+ options = debug
source = bifrost::git+https://github.com/dubhater/vapoursynth-bifrost.git
sha256sums = SKIP
pkgname = vapoursynth-plugin-bifrost-git
-
diff --git a/PKGBUILD b/PKGBUILD
index abae33415e5b..be499c8d05fb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_plug=bifrost
pkgname=vapoursynth-plugin-${_plug}-git
-pkgver=v2.2.2.g3082823
+pkgver=2.2.2.g3082823
pkgrel=1
pkgdesc="Plugin for Vapoursynth: ${_plug} (GIT version)"
arch=('x86_64')
@@ -14,22 +14,23 @@ provides=("vapoursynth-plugin-${_plug}")
conflicts=("vapoursynth-plugin-${_plug}")
source=("${_plug}::git+https://github.com/dubhater/vapoursynth-${_plug}.git")
sha256sums=('SKIP')
+options=('debug')
pkgver() {
cd "${_plug}"
- echo "$(git describe --long --tags | tr - .)"
+ echo "$(git describe --long --tags | tr - . | tr -d v)"
}
prepare() {
mkdir -p build
+}
+build() {
cd "${_plug}"
./autogen.sh
-}
-build() {
- cd build
- ../"${_plug}"/configure \
+ cd "${srcdir}/build"
+ "../${_plug}/configure" \
--prefix=/usr \
--libdir=/usr/lib/vapoursynth