summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD5
2 files changed, 5 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fd1f26e792d9..68e563c459b5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -7,8 +7,9 @@ pkgbase = vapoursynth-plugin-bm3dcuda-git
license = GPL
makedepends = git
makedepends = cmake
+ makedepends = cuda
depends = vapoursynth
- depends = cuda
+ depends = nvidia-utils
provides = vapoursynth-plugin-bm3dcuda
conflicts = vapoursynth-plugin-bm3dcuda
source = bm3dcuda::git+https://github.com/WolframRhodium/VapourSynth-BM3DCUDA.git
diff --git a/PKGBUILD b/PKGBUILD
index b2a9eabe5316..d0db1f5c3464 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,10 +9,11 @@ arch=('x86_64')
url='https://github.com/WolframRhodium/VapourSynth-BM3DCUDA'
license=('GPL')
depends=('vapoursynth'
- 'cuda'
+ 'nvidia-utils'
)
makedepends=('git'
'cmake'
+ 'cuda'
)
provides=("vapoursynth-plugin-${_plug}")
conflicts=("vapoursynth-plugin-${_plug}")
@@ -39,7 +40,7 @@ build() {
cmake --build build
}
-package(){
+package() {
DESTDIR="${pkgdir}" cmake --install build
install -Dm644 "${_plug}/README.md" "${pkgdir}/usr/share/doc/vapoursynth/plugins/${_plug}/README.md"