summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD20
2 files changed, 14 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 66967937aa89..33c8fb5836ca 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,23 +1,21 @@
-# Generated by mksrcinfo v8
-# Fri Mar 15 23:45:51 UTC 2019
pkgbase = vapoursynth-plugin-dfmderainbow-git
pkgdesc = Plugin for Vapoursynth: dfmderainbow (GIT version)
- pkgver = v2.0.g22faeb5
- pkgrel = 2
+ pkgver = 2.2.g44dc654
+ pkgrel = 1
url = https://github.com/dubhater/vapoursynth-dfmderainbow
arch = any
license = GPL
makedepends = git
- depends = vapoursynth
depends = vapoursynth-plugin-temporalmedian-git
depends = vapoursynth-plugin-temporalsoften2-git
- depends = vapoursynth-plugin-fluxsmooth-git
+ depends = vapoursynth-plugin-fluxsmooth
depends = vapoursynth-plugin-msmoosh-git
depends = vapoursynth-plugin-minideen-git
+ depends = vapoursynth-plugin-mvtools
+ depends = vapoursynth-plugin-fft3dfilter-git
provides = vapoursynth-plugin-dfmderainbow
conflicts = vapoursynth-plugin-dfmderainbow
source = dfmderainbow::git+https://github.com/dubhater/vapoursynth-dfmderainbow.git
sha256sums = SKIP
pkgname = vapoursynth-plugin-dfmderainbow-git
-
diff --git a/PKGBUILD b/PKGBUILD
index f3d7657bbcf6..ced966422206 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,20 @@
-# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
+# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
_plug=dfmderainbow
pkgname=vapoursynth-plugin-${_plug}-git
-pkgver=v2.0.g22faeb5
-pkgrel=2
+pkgver=2.2.g44dc654
+pkgrel=1
pkgdesc="Plugin for Vapoursynth: ${_plug} (GIT version)"
arch=('any')
url="https://github.com/dubhater/vapoursynth-${_plug}"
license=('GPL')
-depends=('vapoursynth'
- 'vapoursynth-plugin-temporalmedian-git'
+depends=('vapoursynth-plugin-temporalmedian-git'
'vapoursynth-plugin-temporalsoften2-git'
- 'vapoursynth-plugin-fluxsmooth-git'
+ 'vapoursynth-plugin-fluxsmooth'
'vapoursynth-plugin-msmoosh-git'
'vapoursynth-plugin-minideen-git'
- )
-optdepend=('vapoursynth-plugin-mvtools-git'
- 'vapoursynth-plugin-fft3dfilter-git'
+ 'vapoursynth-plugin-mvtools'
+ 'vapoursynth-plugin-fft3dfilter-git'
)
makedepends=('git')
provides=("vapoursynth-plugin-${_plug}")
@@ -24,11 +22,11 @@ conflicts=("vapoursynth-plugin-${_plug}")
source=("${_plug}::git+https://github.com/dubhater/vapoursynth-${_plug}.git")
sha256sums=('SKIP')
-_site_packages="$(python -c "from distutils.sysconfig import get_python_lib; print(get_python_lib())")"
+_site_packages="$(python -c 'import sysconfig; print(sysconfig.get_paths()["purelib"])')"
pkgver() {
cd "${_plug}"
- echo "$(git describe --long --tags | tr - .)"
+ echo "$(git describe --long --tags | tr - . | tr -d v)"
}
package(){