summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD7
2 files changed, 4 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6ce43c125979..982b1c463ce3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,10 @@
# Generated by mksrcinfo v8
-# Fri Jan 25 23:47:40 UTC 2019
+# Sat Mar 2 19:56:14 UTC 2019
pkgbase = vapoursynth-plugin-inpaint-git
pkgdesc = Plugin for Vapoursynth: inpaint
pkgver = r2.dafa5b5
pkgrel = 1
url = https://github.com/invisiblearts/VapourSynth-Inpaint
- arch = i686
arch = x86_64
license = GPL
makedepends = git
diff --git a/PKGBUILD b/PKGBUILD
index 466a65323822..994ea300b629 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@ pkgname=vapoursynth-plugin-${_plug}-git
pkgver=r2.dafa5b5
pkgrel=1
pkgdesc="Plugin for Vapoursynth: ${_plug}"
-arch=('i686' 'x86_64')
+arch=('x86_64')
url='https://github.com/invisiblearts/VapourSynth-Inpaint'
license=('GPL')
depends=('vapoursynth'
@@ -29,13 +29,12 @@ prepare(){
-i Inpaint.h
echo "all:
- g++ -c -std=gnu++11 -fPIC ${CXXFLAGS} ${CPPFLAGS} -I. $(pkg-config --cflags vapoursynth) $(pkg-config --cflags opencv4) -o Inpaint.o Inpaint.cpp
+ g++ -c -std=gnu++11 -fPIC ${CXXFLAGS} ${CPPFLAGS} -I. $(pkg-config --cflags-only-I vapoursynth) $(pkg-config --cflags-only-I opencv4) -o Inpaint.o Inpaint.cpp
g++ -shared -fPIC ${LDFLAGS} -o lib${_plug}.so Inpaint.o" > Makefile
}
build() {
- cd "${_plug}"
- make
+ make -C "${_plug}"
}
package() {