summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD12
2 files changed, 12 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index edaf3adda9c4..19fa4766da27 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Fri Dec 25 21:27:18 UTC 2015
+# Thu Mar 24 14:02:59 UTC 2016
pkgbase = vapoursynth-plugin-mvtools_sf-git
pkgdesc = Plugin for Vapoursynth: mvtools_sf (GIT version)
- pkgver = test12.2.gfb08881
+ pkgver = test14.1.g58801a8
pkgrel = 1
url = http://forum.doom9.org/showthread.php?t=172525
arch = i686
@@ -13,7 +13,7 @@ pkgbase = vapoursynth-plugin-mvtools_sf-git
depends = fftw
provides = vapoursynth-plugin-mvtools_sf
conflicts = vapoursynth-plugin-mvtools_sf
- source = mvtools_sf::git+https://github.com/IFeelBloated/MVTools_SF.git
+ source = mvtools_sf::git+https://github.com/IFeelBloated/vapoursynth-mvtools-sf
sha1sums = SKIP
pkgname = vapoursynth-plugin-mvtools_sf-git
diff --git a/PKGBUILD b/PKGBUILD
index b1f0fb610b29..13442b2f75f3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_plug=mvtools_sf
pkgname=vapoursynth-plugin-${_plug}-git
-pkgver=test12.2.gfb08881
+pkgver=test14.1.g58801a8
pkgrel=1
pkgdesc="Plugin for Vapoursynth: ${_plug} (GIT version)"
arch=('i686' 'x86_64')
@@ -14,7 +14,7 @@ depends=('vapoursynth'
makedepends=('git')
provides=("vapoursynth-plugin-${_plug}")
conflicts=("vapoursynth-plugin-${_plug}")
-source=("${_plug}::git+https://github.com/IFeelBloated/MVTools_SF.git")
+source=("${_plug}::git+https://github.com/IFeelBloated/vapoursynth-mvtools-sf")
sha1sums=('SKIP')
_sites_packages="$(python -c "from distutils.sysconfig import get_python_lib; print(get_python_lib())")"
@@ -26,12 +26,18 @@ pkgver() {
prepare() {
cd "${_plug}"
+
+ rm -fr src/VapourSynth.h src/VSHelper.h
+
./autogen.sh
}
build() {
cd "${_plug}"
- ./configure --libdir=/usr/lib/vapoursynth
+ CXXFLAGS+=" $(pkg-config --cflags vapoursynth)" \
+ ./configure \
+ --prefix=/usr \
+ --libdir=/usr/lib/vapoursynth
make
}