summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD32
2 files changed, 21 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e77e9b4fb2bf..683bd6224781 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -4,15 +4,15 @@ pkgbase = vapoursynth-plugin-pyd2v-git
pkgrel = 1
url = https://forum.doom9.org/showthread.php?t=180426
arch = any
- license = GPL
+ license = MIT
makedepends = git
- makedepends = python-setuptools
+ makedepends = python-poetry
depends = vapoursynth
+ depends = python-jsonpickle
+ depends = python-click
provides = vapoursynth-plugin-pyd2v
conflicts = vapoursynth-plugin-pyd2v
source = pyd2v::git+https://github.com/rlaPHOENiX/pyd2v.git
- source = setup.py
sha256sums = SKIP
- sha256sums = fd83e9ba64f74d5f4723050495d8e7388241a8fa2a00c7d8c34e7ba0c6e6a77f
pkgname = vapoursynth-plugin-pyd2v-git
diff --git a/PKGBUILD b/PKGBUILD
index 5d30470dcf33..248a8d130d43 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,35 +7,37 @@ pkgrel=1
pkgdesc="Plugin for Vapoursynth: ${_plug} (GIT version)"
arch=('any')
url='https://forum.doom9.org/showthread.php?t=180426'
-license=('GPL')
-depends=('vapoursynth')
+license=('MIT')
+depends=('vapoursynth'
+ 'python-jsonpickle'
+ 'python-click'
+ )
makedepends=('git'
- 'python-setuptools'
+ 'python-poetry'
)
provides=("vapoursynth-plugin-${_plug}")
conflicts=("vapoursynth-plugin-${_plug}")
-source=("${_plug}::git+https://github.com/rlaPHOENiX/pyd2v.git"
- 'setup.py'
- )
-sha256sums=('SKIP'
- 'fd83e9ba64f74d5f4723050495d8e7388241a8fa2a00c7d8c34e7ba0c6e6a77f'
- )
+source=("${_plug}::git+https://github.com/rlaPHOENiX/pyd2v.git")
+sha256sums=('SKIP')
+
+_site_packages="$(python -c "from distutils.sysconfig import get_python_lib; print(get_python_lib())")"
pkgver() {
cd "${_plug}"
echo "$(git describe --long --tags | tr - . | tr -d v)"
}
-prepare() {
- _pkgver=$(pkgver)
- cp setup.py "${_plug}/setup.py"
- sed "s|%%VERSION%%|${_pkgver:0:5}|g" -i "${_plug}/setup.py"
-
+build() {
+ cd "${_plug}"
+ poetry build
}
package() {
cd "${_plug}"
- python setup.py install --root="${pkgdir}/" --optimize=1
+ pip install -I --root "${pkgdir}" --no-warn-script-location --no-deps dist/*.whl
+
+ rm -fr "${pkgdir}${_site_packages}"/{README.md,LICENSE}
install -Dm644 README.md "${pkgdir}/usr/share/doc/vapoursynth/plugins/${_plug}/README.md"
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}