summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD7
2 files changed, 7 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 03476a730155..8e8d90287564 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,15 @@
# Generated by mksrcinfo v8
-# Wed Oct 19 20:55:46 UTC 2016
+# Sat Mar 2 19:59:18 UTC 2019
pkgbase = vapoursynth-plugin-sharpaamcmod-git
pkgdesc = Plugin for Vapoursynth: sharpaamcmod (GIT version)
- pkgver = r4
+ pkgver = r5
pkgrel = 1
url = https://gist.github.com/4re
arch = any
license = GPL
makedepends = git
depends = vapoursynth
- depends = vapoursynth-plugin-havsfunc
+ depends = vapoursynth-plugin-havsfunc-git
provides = vapoursynth-plugin-sharpaamcmod
conflicts = vapoursynth-plugin-sharpaamcmod
source = sharpaamcmod::git+https://gist.github.com/8fee7aa32ba9ac566ed0.git
diff --git a/PKGBUILD b/PKGBUILD
index b9ebfba07fb8..797ccf03141f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,14 +2,14 @@
_plug=sharpaamcmod
pkgname=vapoursynth-plugin-${_plug}-git
-pkgver=r4
+pkgver=r5
pkgrel=1
pkgdesc="Plugin for Vapoursynth: ${_plug} (GIT version)"
arch=('any')
url='https://gist.github.com/4re'
license=('GPL')
depends=('vapoursynth'
- 'vapoursynth-plugin-havsfunc'
+ 'vapoursynth-plugin-havsfunc-git'
)
makedepends=('git')
provides=("vapoursynth-plugin-${_plug}")
@@ -25,7 +25,8 @@ pkgver() {
}
package() {
- install -Dm644 "${_plug}/${_plug}.py" "${pkgdir}${_site_packages}/${_plug}.py"
+ cd "${_plug}"
+ install -Dm644 "${_plug}.py" "${pkgdir}${_site_packages}/${_plug}.py"
python -m compileall -q -f -d "${_site_packages}" "${pkgdir}${_site_packages}/${_plug}.py"
python -OO -m compileall -q -f -d "${_site_packages}" "${pkgdir}${_site_packages}/${_plug}.py"
}