summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD9
2 files changed, 10 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f1a2afa20686..98f87b27f469 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = vapoursynth-plugin-tcanny-git
pkgdesc = Plugin for Vapoursynth: tcanny (GIT version)
- pkgver = 14.0.g14d7a15
+ pkgver = 14.1.g14ac2ce
pkgrel = 1
url = https://forum.doom9.org/showthread.php?t=171136
arch = x86_64
@@ -9,6 +9,7 @@ pkgbase = vapoursynth-plugin-tcanny-git
makedepends = boost
makedepends = opencl-headers
makedepends = meson
+ makedepends = clang
depends = vapoursynth
depends = opencl-icd-loader
provides = vapoursynth-plugin-tcanny
diff --git a/PKGBUILD b/PKGBUILD
index baea3e741ca6..37d721605741 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_plug=tcanny
pkgname=vapoursynth-plugin-${_plug}-git
-pkgver=14.0.g14d7a15
+pkgver=14.1.g14ac2ce
pkgrel=1
pkgdesc="Plugin for Vapoursynth: ${_plug} (GIT version)"
arch=('x86_64')
@@ -15,6 +15,7 @@ makedepends=('git'
'boost'
'opencl-headers'
'meson'
+ 'clang'
)
provides=("vapoursynth-plugin-${_plug}")
conflicts=("vapoursynth-plugin-${_plug}")
@@ -32,6 +33,12 @@ prepare() {
}
build() {
+
+ export CC=clang
+ export CXX=clang++
+ export CFLAGS="${CFLAGS/-fvar-tracking-assignments/}"
+ export CXXFLAGS="${CXXFLAGS/-fvar-tracking-assignments/}"
+
cd build
arch-meson "../${_plug}" \
--buildtype=release \