summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD15
2 files changed, 10 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4f42b0b00d34..a563a98aa8fb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,6 @@
-# Generated by mksrcinfo v8
-# Sat Mar 2 20:01:16 UTC 2019
pkgbase = vapoursynth-plugin-videoscope-git
pkgdesc = Plugin for Vapoursynth: videoscope (GIT version)
- pkgver = v1.0.2.g527b9b0
+ pkgver = 1.0.2.g527b9b0
pkgrel = 1
url = https://github.com/dubhater/vapoursynth-videoscope
arch = x86_64
@@ -11,10 +9,10 @@ pkgbase = vapoursynth-plugin-videoscope-git
depends = vapoursynth
provides = vapoursynth-plugin-videoscope
conflicts = vapoursynth-plugin-videoscope
+ options = debug
source = videoscope::git+https://github.com/dubhater/vapoursynth-videoscope.git
source = COPYING::http://www.wtfpl.net/txt/copying/
sha256sums = SKIP
sha256sums = 0356258391e190dc1d44ea01565cfe627fe44e27dad693a0a54c2483a7b223e5
pkgname = vapoursynth-plugin-videoscope-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 7112cd4c9e61..8d2dc971ba01 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
-# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
+# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
_plug=videoscope
pkgname=vapoursynth-plugin-${_plug}-git
-pkgver=v1.0.2.g527b9b0
+pkgver=1.0.2.g527b9b0
pkgrel=1
pkgdesc="Plugin for Vapoursynth: ${_plug} (GIT version)"
arch=('x86_64')
@@ -17,22 +17,23 @@ source=("${_plug}::git+https://github.com/dubhater/vapoursynth-${_plug}.git"
sha256sums=('SKIP'
'0356258391e190dc1d44ea01565cfe627fe44e27dad693a0a54c2483a7b223e5'
)
+options=('debug')
pkgver() {
cd "${_plug}"
- echo "$(git describe --long --tags | tr - .)"
+ echo "$(git describe --long --tags | tr - . | tr -d v)"
}
prepare() {
mkdir -p build
+}
+build() {
cd "${_plug}"
./autogen.sh
-}
-build() {
- cd build
- ../"${_plug}"/configure \
+ cd "${srcdir}/build"
+ "../${_plug}/configure" \
--prefix=/usr \
--libdir=/usr/lib/vapoursynth