summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD36
3 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0aa1fa838967
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = vapoursynth-tools-audiocutter-git
+ pkgdesc = Tools for Vapoursynth: audiocutter (GIT version)
+ pkgver = r26.c518e30
+ pkgrel = 1
+ url = https://github.com/AzraelNewtype/audiocutter
+ arch = any
+ license = GPL
+ makedepends = git
+ depends = vapoursynth
+ depends = mkvtoolnix
+ provides = vapoursynth-tools-audiocutter
+ conflicts = vapoursynth-tools-audiocutter
+ source = audiocutter::git+https://github.com/AzraelNewtype/audiocutter.git
+ sha256sums = SKIP
+
+pkgname = vapoursynth-tools-audiocutter-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..05c6d4d4c97b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4cf0ea8a2fcf
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
+
+_plug=audiocutter
+pkgname=vapoursynth-tools-${_plug}-git
+pkgver=r26.c518e30
+pkgrel=1
+pkgdesc="Tools for Vapoursynth: ${_plug} (GIT version)"
+arch=('any')
+url="https://github.com/AzraelNewtype/${_plug}"
+license=('GPL')
+depends=('vapoursynth'
+ 'mkvtoolnix'
+ )
+makedepends=('git')
+provides=("vapoursynth-tools-${_plug}")
+conflicts=("vapoursynth-tools-${_plug}")
+source=("${_plug}::git+https://github.com/AzraelNewtype/${_plug}.git")
+sha256sums=('SKIP')
+
+_site_packages="$(python -c "from distutils.sysconfig import get_python_lib; print(get_python_lib())")"
+
+pkgver() {
+ cd "${_plug}"
+# echo "$(git describe --long --tags | tr - .)"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package(){
+ cd "${_plug}"
+ install -Dm644 audiocutter.py "${pkgdir}${_site_packages}/${_plug}.py"
+ python -m compileall -q -f -d "${_site_packages}" "${pkgdir}${_site_packages}/${_plug}.py"
+ python -OO -m compileall -q -f -d "${_site_packages}" "${pkgdir}${_site_packages}/${_plug}.py"
+
+ install -Dm644 README.md "${pkgdir}/usr/share/doc/vapoursynth/tools/${_plug}/README.md"
+ install -Dm644 example.vpy "${pkgdir}/usr/share/doc/vapoursynth/tools/${_plug}/example.vpy"
+}