summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO35
-rw-r--r--.gitignore4
-rwxr-xr-xPKGBUILD52
-rwxr-xr-xvasisualy-pi6
-rwxr-xr-xvasisualy-qt6
5 files changed, 103 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6a2c5a1584db
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,35 @@
+pkgbase = vasisualy-git
+ pkgdesc = Vasisualy is a simple Russian voice assistant written on python 3 for GNU/Linux and Windows.
+ pkgver = r85.20210115
+ pkgrel = 1
+ url = https://github.com/Oknolaz/vasisualy
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ depends = python>3
+ depends = rhvoice
+ depends = speech-dispatcher
+ depends = python-pyqt5
+ depends = python-vlc
+ depends = python-shell
+ depends = python-pyowm
+ depends = python-mss
+ depends = python-wikipedia
+ depends = python-geocoder
+ depends = python-googletrans
+ depends = python-lxml
+ depends = python-beautifulsoup4
+ depends = python-qt-material
+ depends = python-speechrecognition
+ provides = vasisualy
+ conflicts = vasisualy
+ source = vasisualy-git::git+https://github.com/Oknolaz/vasisualy.git
+ source = vasisualy-pi
+ source = vasisualy-qt
+ sha256sums = SKIP
+ sha256sums = d3a24f37d7c5012d33f52a7042ea4ae022d61f4e5f55a25e5e1515d63f4eecef
+ sha256sums = 0e477f3fca6b51af6822c1c67e2e48e2d1b1c95b608025b64c9d9132e0c8aea3
+
+pkgname = vasisualy-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..4f518972149f
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/pkg/*
+/src/*
+/vasisualy-git/*
+/vasisualy-git-r*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..e1638d1e1570
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,52 @@
+# Contributor: vantu5z <vantu5z@mail.ru>
+
+pkgname=vasisualy-git
+pkgver=r85.20210115
+pkgrel=1
+pkgdesc="Vasisualy is a simple Russian voice assistant written on python 3 for GNU/Linux and Windows."
+arch=('i686' 'x86_64')
+url="https://github.com/Oknolaz/vasisualy"
+license=('GPL3')
+depends=('python>3' 'rhvoice' 'speech-dispatcher' 'python-pyqt5' 'python-vlc'
+ 'python-shell' 'python-pyowm' 'python-mss' 'python-wikipedia'
+ 'python-geocoder' 'python-googletrans' 'python-lxml'
+ 'python-beautifulsoup4' 'python-qt-material' 'python-speechrecognition')
+makedepends=('git')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+source=($pkgname::'git+https://github.com/Oknolaz/vasisualy.git'
+ 'vasisualy-pi' 'vasisualy-qt')
+sha256sums=('SKIP'
+ 'd3a24f37d7c5012d33f52a7042ea4ae022d61f4e5f55a25e5e1515d63f4eecef'
+ '0e477f3fca6b51af6822c1c67e2e48e2d1b1c95b608025b64c9d9132e0c8aea3')
+
+pkgver() {
+ cd $pkgname
+ # get number of last git commit
+ _commitCount=$(git rev-list --count HEAD)
+ # get time of last git commit
+ _commitTime=$(git show -s --format="%ci" | grep -o "....-..-.." | sed "s/-//g")
+ # add "r*.*" from package version
+ echo "r$_commitCount.$_commitTime"
+}
+
+package()
+{
+ site_pkg=$(python -c "import site; print(site.getsitepackages()[0])")
+ modulename=${pkgname%-git}
+
+ cd $srcdir
+
+ install -Dm0644 "vasisualy-pi" "${pkgdir}/usr/bin/vasisualy-pi"
+ install -Dm0644 "vasisualy-qt" "${pkgdir}/usr/bin/vasisualy-qt"
+
+ cd $pkgname
+
+ install -Dm0644 "vasisualy-pi.py" "${pkgdir}/${site_pkg}/${modulename}/vasisualy-pi.py"
+ install -Dm0644 "vasisualy-qt.py" "${pkgdir}/${site_pkg}/${modulename}/vasisualy-qt.py"
+ cp -R "assets" "${pkgdir}/${site_pkg}/${modulename}"
+ cp -R "music" "${pkgdir}/${site_pkg}/${modulename}"
+ cp -R "ui" "${pkgdir}/${site_pkg}/${modulename}"
+
+ install -Dm0644 LICENSE "${pkgdir}/usr/share/licenses/${modulename}/LICENSE"
+}
diff --git a/vasisualy-pi b/vasisualy-pi
new file mode 100755
index 000000000000..c941959734a1
--- /dev/null
+++ b/vasisualy-pi
@@ -0,0 +1,6 @@
+#!/usr/bin/env python3
+# -*- coding: utf-8 -*-
+
+main = __import__('vasisualy.vasisualy-pi')
+
+main()
diff --git a/vasisualy-qt b/vasisualy-qt
new file mode 100755
index 000000000000..830b4ce8c02a
--- /dev/null
+++ b/vasisualy-qt
@@ -0,0 +1,6 @@
+#!/usr/bin/env python3
+# -*- coding: utf-8 -*-
+
+main = __import__('vasisualy.vasisualy-qt')
+
+main()