summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD16
3 files changed, 14 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5c3d5ad1ff4e..bdd27b53d660 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,15 @@
pkgbase = vazir-code-fonts
pkgdesc = A beautiful monospace Persian font based on Vazir and Inconsolata fonts.
- pkgver = 1.1.0
- pkgrel = 2
+ pkgver = 1.1.1
+ pkgrel = 1
url = https://github.com/rastikerdar/vazir-code-font
arch = any
license = OFL
depends = fontconfig
provides = ttf-vazir-code
conflicts = ttf-vazir-code
- source = vazir-code-fonts-1.1.0.zip::https://github.com/rastikerdar/vazir-code-font/releases/download/v1.1.0/vazir-code-font-v1.1.0.zip
- source = vazir-code-fonts-WOL-1.1.0.zip::https://github.com/rastikerdar/vazir-code-font/releases/download/v1.1.0/vazir-code-font-without-latin-v1.1.0.zip
- sha256sums = cbe65897efc5e68244f678b39fe0c94c0c1390601faba45280a5c4fb2bf2b63c
- sha256sums = 3b6ee046e3ee7185cda99ec009c5676e28c90cb7ebfaf09ebb8e09249d861f1f
+ source = vazir-code-fonts-1.1.1.zip::https://github.com/rastikerdar/vazir-code-font/releases/download/v1.1.1/vazir-code-font-v1.1.1.zip
+ sha256sums = fa8032f57798cceaf06de9bf10e5fbcfd194d9bde48c42f5eb44ab3ceeda015f
pkgname = vazir-code-fonts
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..eefe248134fd
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+vazir-code-fonts-*
+pkg/
+src/
diff --git a/PKGBUILD b/PKGBUILD
index 7498a628bcb4..1c3fc551eb2a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,9 @@
-# $Id$
-# Maintainer: Mohammadreza Abdollahzadeh <morealaz at gmail dot com>
+# Maintainer: Ali Molaei <ali dot molaei at protonmail dot com>
+# Contributor: Mohammadreza Abdollahzadeh <morealaz at gmail dot com>
pkgname=vazir-code-fonts
-pkgver=1.1.0
-pkgrel=2
+pkgver=1.1.1
+pkgrel=1
pkgdesc="A beautiful monospace Persian font based on Vazir and Inconsolata fonts."
url="https://github.com/rastikerdar/vazir-code-font"
arch=(any)
@@ -11,14 +11,12 @@ license=('OFL')
depends=('fontconfig')
provides=('ttf-vazir-code')
conflicts=('ttf-vazir-code')
-source=("${pkgname}-${pkgver}.zip::${url}/releases/download/v${pkgver}/vazir-code-font-v${pkgver}.zip"
- "${pkgname}-WOL-${pkgver}.zip::${url}/releases/download/v${pkgver}/vazir-code-font-without-latin-v${pkgver}.zip")
-sha256sums=('cbe65897efc5e68244f678b39fe0c94c0c1390601faba45280a5c4fb2bf2b63c'
- '3b6ee046e3ee7185cda99ec009c5676e28c90cb7ebfaf09ebb8e09249d861f1f')
+source=("${pkgname}-${pkgver}.zip::${url}/releases/download/v${pkgver}/vazir-code-font-v${pkgver}.zip")
+sha256sums=('fa8032f57798cceaf06de9bf10e5fbcfd194d9bde48c42f5eb44ab3ceeda015f')
package() {
install -d "${pkgdir}/usr/share/fonts/${pkgname%-fonts}"
- install -t "${pkgdir}/usr/share/fonts/${pkgname%-fonts}" -m644 ./{,Without-Latin/}Vazir-Code*.ttf
+ install -t "${pkgdir}/usr/share/fonts/${pkgname%-fonts}" -m644 ./Vazir-Code*.ttf
install -Dm644 ./LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}
# vim:set ts=2 sw=2 et: