summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD13
-rw-r--r--fix_compile_error.patch26
3 files changed, 6 insertions, 41 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ad505b95d898..be5c97bc2f5f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = vboot-utils
pkgdesc = Chromium OS verified boot utilities
- pkgver = 43.6946
+ pkgver = 44.7077
pkgrel = 1
url = https://chromium.googlesource.com/chromiumos/platform/vboot_reference
arch = i686
@@ -10,10 +10,8 @@ pkgbase = vboot-utils
makedepends = trousers
depends = libutil-linux
depends = openssl
- source = fix_compile_error.patch
- source = https://chromium.googlesource.com/chromiumos/platform/vboot_reference/+archive/refs/heads/release-R43-6946.B.tar.gz
- sha1sums = a00c70b5c23b438361865cd2450851f0a71af720
- sha1sums = SKIP
+ source = https://chromium.googlesource.com/chromiumos/platform/vboot_reference/+archive/refs/heads/release-R44-7077.B.tar.gz
+ sha1sums = 791308e35dc867ec33879dd7add9c1eb3a22c7b1
pkgname = vboot-utils
diff --git a/PKGBUILD b/PKGBUILD
index 322f662785b2..408676348db4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=vboot-utils
pkgdesc='Chromium OS verified boot utilities'
-pkgver=43.6946
+pkgver=44.7077
_tag=release-R${pkgver/\./-}.B
pkgrel=1
arch=(i686 x86_64)
@@ -11,15 +11,8 @@ url='https://chromium.googlesource.com/chromiumos/platform/vboot_reference'
license=('custom:chromiumos')
depends=(libutil-linux openssl)
makedepends=(libyaml trousers)
-source=(
- fix_compile_error.patch
- https://chromium.googlesource.com/chromiumos/platform/vboot_reference/+archive/refs/heads/$_tag.tar.gz)
-sha1sums=('a00c70b5c23b438361865cd2450851f0a71af720'
- 'SKIP')
-
-prepare() {
- patch -p1 < fix_compile_error.patch
-}
+source=(https://chromium.googlesource.com/chromiumos/platform/vboot_reference/+archive/refs/heads/$_tag.tar.gz)
+sha1sums=('791308e35dc867ec33879dd7add9c1eb3a22c7b1')
build() {
make
diff --git a/fix_compile_error.patch b/fix_compile_error.patch
deleted file mode 100644
index 83fe3349ca49..000000000000
--- a/fix_compile_error.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-diff --git a/futility/futility.c b/futility/futility.c
-index 60cc9c5..6cea681 100644
---- a/futility/futility.c
-+++ b/futility/futility.c
-@@ -230,7 +230,7 @@ static int run_command(const struct futil_cmd_t *cmd, int argc, char *argv[])
- static int do_help(int argc, char *argv[])
- {
- const struct futil_cmd_t *cmd;
-- const char *vstr;
-+ const char *vstr = "";
-
- /* Help about a known command? */
- if (argc > 1) {
-diff --git a/host/lib21/host_misc.c b/host/lib21/host_misc.c
-index db5e824..ee9426a 100644
---- a/host/lib21/host_misc.c
-+++ b/host/lib21/host_misc.c
-@@ -138,7 +138,7 @@ static const char *onebyte(const char *str, uint8_t *vptr)
-
- int vb2_str_to_id(const char *str, struct vb2_id *id)
- {
-- uint8_t val;
-+ uint8_t val = 0;
- int i;
-
- if (!str)