summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD37
-rw-r--r--fix_compile_error.patch26
3 files changed, 82 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ad505b95d898
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = vboot-utils
+ pkgdesc = Chromium OS verified boot utilities
+ pkgver = 43.6946
+ pkgrel = 1
+ url = https://chromium.googlesource.com/chromiumos/platform/vboot_reference
+ arch = i686
+ arch = x86_64
+ license = custom:chromiumos
+ makedepends = libyaml
+ makedepends = trousers
+ depends = libutil-linux
+ depends = openssl
+ source = fix_compile_error.patch
+ source = https://chromium.googlesource.com/chromiumos/platform/vboot_reference/+archive/refs/heads/release-R43-6946.B.tar.gz
+ sha1sums = a00c70b5c23b438361865cd2450851f0a71af720
+ sha1sums = SKIP
+
+pkgname = vboot-utils
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..322f662785b2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Anatol Pomozov <anatol.pomozov@gmail.com>
+# Contributor: Thomas Sowell <tom@fancydriving.org>
+
+pkgname=vboot-utils
+pkgdesc='Chromium OS verified boot utilities'
+pkgver=43.6946
+_tag=release-R${pkgver/\./-}.B
+pkgrel=1
+arch=(i686 x86_64)
+url='https://chromium.googlesource.com/chromiumos/platform/vboot_reference'
+license=('custom:chromiumos')
+depends=(libutil-linux openssl)
+makedepends=(libyaml trousers)
+source=(
+ fix_compile_error.patch
+ https://chromium.googlesource.com/chromiumos/platform/vboot_reference/+archive/refs/heads/$_tag.tar.gz)
+sha1sums=('a00c70b5c23b438361865cd2450851f0a71af720'
+ 'SKIP')
+
+prepare() {
+ patch -p1 < fix_compile_error.patch
+}
+
+build() {
+ make
+}
+
+check() {
+ make runtests
+}
+
+package() {
+ make DESTDIR="$pkgdir" MINIMAL=1 install
+ install -d "$pkgdir"/usr/share/vboot/
+ cp -r tests/devkeys "$pkgdir"/usr/share/vboot/devkeys
+ install -m 644 -D LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+}
diff --git a/fix_compile_error.patch b/fix_compile_error.patch
new file mode 100644
index 000000000000..83fe3349ca49
--- /dev/null
+++ b/fix_compile_error.patch
@@ -0,0 +1,26 @@
+diff --git a/futility/futility.c b/futility/futility.c
+index 60cc9c5..6cea681 100644
+--- a/futility/futility.c
++++ b/futility/futility.c
+@@ -230,7 +230,7 @@ static int run_command(const struct futil_cmd_t *cmd, int argc, char *argv[])
+ static int do_help(int argc, char *argv[])
+ {
+ const struct futil_cmd_t *cmd;
+- const char *vstr;
++ const char *vstr = "";
+
+ /* Help about a known command? */
+ if (argc > 1) {
+diff --git a/host/lib21/host_misc.c b/host/lib21/host_misc.c
+index db5e824..ee9426a 100644
+--- a/host/lib21/host_misc.c
++++ b/host/lib21/host_misc.c
+@@ -138,7 +138,7 @@ static const char *onebyte(const char *str, uint8_t *vptr)
+
+ int vb2_str_to_id(const char *str, struct vb2_id *id)
+ {
+- uint8_t val;
++ uint8_t val = 0;
+ int i;
+
+ if (!str)