summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD23
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8d5bc635334a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = vc4clstdlib-git
+ pkgdesc = VC4CL implementation of the OpenCL standard-library and is required to build the VC4C compiler
+ pkgver = 1
+ pkgrel = 1
+ url = https://github.com/doe300/VC4CLStdLib
+ arch = any
+ license = MIT
+ makedepends = git
+ provides = opencl-pi
+ provides = opencl-vc4
+ provides = opencl-driver
+ source = https://github.com/doe300/VC4CLStdLib/archive/master.tar.gz
+ md5sums = SKIP
+
+pkgname = vc4clstdlib-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1734c2b99b4e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: satcom886 <rostik.medved@gmail.com>
+
+pkgname=vc4clstdlib-git
+pkgver=1
+pkgrel=1
+pkgdesc="VC4CL implementation of the OpenCL standard-library and is required to build the VC4C compiler"
+arch=('any')
+url="https://github.com/doe300/VC4CLStdLib"
+license=('MIT')
+groups=()
+depends=()
+makedepends=('git')
+optdepends=()
+provides=('opencl-pi' 'opencl-vc4' 'opencl-driver')
+source=("https://github.com/doe300/VC4CLStdLib/archive/master.tar.gz")
+md5sums=('SKIP')
+_reponame=VC4CLStdLib
+
+package() {
+ cd $srcdir/_$reponame-master
+ mkdir -p $pkgdir/usr/include/$pkgname/include
+ cp include/* $pkgdir/usr/include/$pkgname/include/
+}