summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO33
-rw-r--r--PKGBUILD42
-rw-r--r--vcmi.install57
3 files changed, 132 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d2a4565c7532
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,33 @@
+pkgbase = vcmi
+ pkgdesc = Heroes of Might and Magic 3 game engine
+ pkgver = 0.98
+ pkgrel = 1
+ url = http://forum.vcmi.eu/portal.php
+ install = vcmi.install
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = boost
+ makedepends = cmake
+ depends = boost-libs
+ depends = ffmpeg
+ depends = sdl2_image
+ depends = sdl2_mixer
+ depends = sdl2_ttf
+ depends = qt5-base
+ depends = libxkbcommon-x11
+ depends = desktop-file-utils
+ depends = gtk-update-icon-cache
+ depends = hicolor-icon-theme
+ depends = minizip
+ optdepends = innoextract: required by vcmibuilder
+ optdepends = unshield: required by vcmibuilder
+ optdepends = unzip: required by vcmibuilder
+ options = !makeflags
+ options = strip
+ options = debug
+ source = vcmi-0.98.tar.gz::https://github.com/vcmi/vcmi/archive/0.98.tar.gz
+ md5sums = 6a69e52a3380358220eba67332b097c6
+
+pkgname = vcmi
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..92d10fb60885
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Raziel23 <venom23 at runbox dot com>
+
+pkgname=vcmi
+pkgver=0.98
+pkgrel=1
+pkgdesc="Heroes of Might and Magic 3 game engine"
+arch=('i686' 'x86_64')
+url="http://forum.vcmi.eu/portal.php"
+license=('GPL2')
+depends=('boost-libs' 'ffmpeg' 'sdl2_image' 'sdl2_mixer' 'sdl2_ttf' 'qt5-base' 'libxkbcommon-x11'
+ 'desktop-file-utils' 'gtk-update-icon-cache' 'hicolor-icon-theme' 'minizip')
+makedepends=('boost' 'cmake')
+optdepends=('innoextract: required by vcmibuilder'
+ 'unshield: required by vcmibuilder'
+ 'unzip: required by vcmibuilder')
+options=('!makeflags' 'strip' 'debug')
+install="$pkgname.install"
+source=("$pkgname-$pkgver.tar.gz::https://github.com/vcmi/$pkgname/archive/$pkgver.tar.gz")
+md5sums=('6a69e52a3380358220eba67332b097c6')
+
+prepare() {
+ # Remove the last build.
+ [[ -d "$pkgname-$pkgver-build" ]] && rm -rf "$pkgname-$pkgver-build"
+ mkdir "$pkgname-$pkgver-build"
+}
+
+build() {
+ cd "$pkgname-$pkgver-build"
+ cmake "../$pkgname-$pkgver" \
+ -DCMAKE_INSTALL_PREFIX='/usr' \
+ -DCMAKE_INSTALL_LIBDIR='lib' \
+ -DCMAKE_SKIP_RPATH='FALSE' \
+ -DCMAKE_BUILD_TYPE='RelWithDebInfo'
+ make
+}
+
+package() {
+ cd "$pkgname-$pkgver-build"
+ make DESTDIR="$pkgdir" install
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/vcmi.install b/vcmi.install
new file mode 100644
index 000000000000..34c243f2ebb2
--- /dev/null
+++ b/vcmi.install
@@ -0,0 +1,57 @@
+post_install() {
+ update-desktop-database -q
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+
+ echo ">>>"
+ echo ">>> Vcmi is a game engine and it doesn't contain data files. Therefore you have to have"
+ echo ">>> an original copy of Heroes of Might and Magic 3 Shadow of Death or Complete edition."
+ echo ">>> You can prepare the data files by using a vcmibuilder script (which is the easiest"
+ echo ">>> and recommended method) or you can make this manually."
+ echo ">>>"
+ echo ">>> The following step describe how to prepare data files by using the vcmibuilder script:"
+ echo ">>> 1. Execute as normal user the vcmibuilder script with appropriate options and paths"
+ echo ">>> (depending on what kind of HOMM3 copy you have). It will automatically create"
+ echo ">>> a directory ~/.local/share/vcmi where will be prepared the data files:"
+ echo ">>> a. if you have HOMM3 with one or two CD's run the following command"
+ echo ">>> (vcmibuilder will require unshield and unzip tools):"
+ echo ">>> vcmibuilder --cd1 /path/to/iso/or/cd --cd2 /path/to/second/cd"
+ echo ">>> b. or if you have HOMM3 installer from gog.com run the following command"
+ echo ">>> (vcmibuilder will require innoextract and unzip tools):"
+ echo ">>> vcmibuilder --gog /path/to/gog.com/installer"
+ echo ">>> c. or if you have HOMM3 that is already installed run the following command"
+ echo ">>> (vcmibuilder will require unzip tool):"
+ echo ">>> vcmibuilder --data /path/to/h3/data"
+ echo ">>>"
+ echo ">>> Now you can run vcmi as a normal user by running vcmiclient command. Please also check"
+ echo ">>> vcmilauncher (mod manager) which can automatically download and manage available mods."
+ echo ">>>"
+ echo ">>> Vcmi will read data files from ~/.local/share/vcmi directory. Temporary files including"
+ echo ">>> logs will be located in ~/.cache/vcmi directory and configuration files will be located"
+ echo ">>> in ~/.config/vcmi directory."
+ echo ">>>"
+ echo ">>> More information about vcmi linux installation can be found on this website:"
+ echo ">>> http://wiki.vcmi.eu/index.php?title=Installation_on_Linux"
+ echo ">>>"
+ echo ">>> Below is included a bunch of useful links about vcmi:"
+ echo ">>> - (vcmi wiki): http://wiki.vcmi.eu/index.php?title=Main_Page"
+ echo ">>> - (vcmi forum): http://forum.vcmi.eu/"
+ echo ">>> - (vcmi bug tracker): http://bugs.vcmi.eu/my_view_page.php"
+ echo ">>> - (how to report a bug): http://wiki.vcmi.eu/index.php?title=Bug_reporting_guidelines"
+ echo ">>> - (the latest vcmi changelog): http://forum.vcmi.eu/viewtopic.php?p=14153#14153"
+ echo ">>>"
+}
+
+post_upgrade() {
+ update-desktop-database -q
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+}
+
+post_remove() {
+ update-desktop-database -q
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+
+ echo ">>>"
+ echo ">>> In order to completely remove vcmi you will need to manually remove"
+ echo ">>> ~/.local/share/vcmi, ~/.cache/vcmi and ~/.config/vcmi directories."
+ echo ">>>"
+}