summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PKGBUILD10
1 files changed, 8 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 438a507933bd..1b7a82060b97 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
pkgname=vcsn-git
_realname=vcsn
-pkgver=v2.0.r1065.g650cb77
-pkgrel=3
+pkgver=v2.1.r384.g74679ab
+pkgrel=1
pkgdesc="Finite state machine manipulation platform, consisting of a library and tools implemented on top of it."
arch=('i686' 'x86_64')
url="http://vaucanson.lrde.epita.fr/"
@@ -12,6 +12,7 @@ depends=('boost' 'gcc' 'ccache' 'libltdl' 'jupyter' 'mathjax' 'graphviz')
makedepends=('git' 'texlive-core' 'doxygen' 'python2-docutils')
conflicts=('vaucanson-git' 'vaucanson' 'vcsn')
provides=('vaucanson-git' 'vaucanson' 'vcsn')
+options=(!buildflags)
source=(git+https://gitlab.lrde.epita.fr/vcsn/vcsn.git)
md5sums=('SKIP')
@@ -21,6 +22,11 @@ pkgver() {
git describe --long | sed -r 's/([^-]*-g)/r\1/;s/-/./g'
}
+check() {
+ cd "$srcdir/${_realname}"
+ ./tests/bin/vcsn python -c 'import vcsn; vcsn.B.expression("a").automaton()'
+}
+
build() {
cd "$srcdir/${_realname}"
./bootstrap